summaryrefslogtreecommitdiff
path: root/dev-php/pecl-pam/pecl-pam-1.0.3-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-27 22:40:05 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-03-27 22:40:05 +0100
commit8c364c784966be1700ea39ae45028f3e9be9cae0 (patch)
treec1971211069b79e3831b71accd52a67a9fdc77a3 /dev-php/pecl-pam/pecl-pam-1.0.3-r3.ebuild
parent6bd95d1f6320b8666a31ec949183aaa3088aa16f (diff)
gentoo resync : 27.03.2018
Diffstat (limited to 'dev-php/pecl-pam/pecl-pam-1.0.3-r3.ebuild')
-rw-r--r--dev-php/pecl-pam/pecl-pam-1.0.3-r3.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-php/pecl-pam/pecl-pam-1.0.3-r3.ebuild b/dev-php/pecl-pam/pecl-pam-1.0.3-r3.ebuild
new file mode 100644
index 000000000000..db57bd508765
--- /dev/null
+++ b/dev-php/pecl-pam/pecl-pam-1.0.3-r3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PHP_EXT_NAME="pam"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS=( README )
+
+USE_PHP="php5-6 php7-0 php7-1 php7-2"
+
+inherit php-ext-pecl-r3 pam
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="This extension provides PAM (Pluggable Authentication Modules) integration"
+LICENSE="PHP-2.02"
+SLOT="0"
+IUSE="debug"
+
+DEPEND="sys-libs/pam"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${PV}-php7.patch" )
+
+src_prepare() {
+ #Fix DOS line endings
+ sed -i 's/\r$//' -- pam.c || die
+ php-ext-source-r3_src_prepare
+}
+
+src_configure() {
+ local PHP_EXT_ECONF_ARGS=( --with-pam=/usr $(use_enable debug) )
+ php-ext-source-r3_src_configure
+}
+
+src_install() {
+ pamd_mimic_system php auth account password
+ php-ext-pecl-r3_src_install
+}