summaryrefslogtreecommitdiff
path: root/dev-php/pecl-mongodb/pecl-mongodb-1.3.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-php/pecl-mongodb/pecl-mongodb-1.3.3.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-php/pecl-mongodb/pecl-mongodb-1.3.3.ebuild')
-rw-r--r--dev-php/pecl-mongodb/pecl-mongodb-1.3.3.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-php/pecl-mongodb/pecl-mongodb-1.3.3.ebuild b/dev-php/pecl-mongodb/pecl-mongodb-1.3.3.ebuild
new file mode 100644
index 000000000000..ad063c40f913
--- /dev/null
+++ b/dev-php/pecl-mongodb/pecl-mongodb-1.3.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PHP_EXT_NAME="mongodb"
+USE_PHP="php5-6 php7-0 php7-1"
+
+inherit php-ext-pecl-r3
+
+DESCRIPTION="MongoDB database driver for PHP"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="libressl sasl"
+
+RDEPEND="
+ php_targets_php5-6? ( dev-lang/php:5.6[json,ssl,zlib] )
+ php_targets_php7-0? ( dev-lang/php:7.0[json,ssl,zlib] )
+ php_targets_php7-1? ( dev-lang/php:7.1[json,ssl,zlib] )
+ >=dev-libs/libbson-1.8.2
+ >=dev-libs/mongo-c-driver-1.8.2[sasl?,ssl]
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ sasl? ( dev-libs/cyrus-sasl )
+"
+# pkgconfig needed if system libraries are used for bson and libmongoc
+DEPEND="${RDEPEND} virtual/pkgconfig"
+
+src_configure() {
+ local PHP_EXT_ECONF_ARGS=(
+ --enable-mongodb
+ --with-libbson
+ --with-libmongoc
+ --with-mongodb-sasl=$(usex sasl)
+ )
+ php-ext-source-r3_src_configure
+}