summaryrefslogtreecommitdiff
path: root/dev-php/pecl-gnupg/pecl-gnupg-1.4.0-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-21 18:59:32 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-21 18:59:32 +0100
commit520a5b56dff7c24c9d42eafec142cb78b44f8e3e (patch)
treef562f705600dbd2292e97c0b4145787c2a8d1f97 /dev-php/pecl-gnupg/pecl-gnupg-1.4.0-r2.ebuild
parent3811bc3072bf19e2be351d2c63f81532945c0f21 (diff)
gentoo resync : 21.07.2018
Diffstat (limited to 'dev-php/pecl-gnupg/pecl-gnupg-1.4.0-r2.ebuild')
-rw-r--r--dev-php/pecl-gnupg/pecl-gnupg-1.4.0-r2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-php/pecl-gnupg/pecl-gnupg-1.4.0-r2.ebuild b/dev-php/pecl-gnupg/pecl-gnupg-1.4.0-r2.ebuild
new file mode 100644
index 000000000000..d4642afe226e
--- /dev/null
+++ b/dev-php/pecl-gnupg/pecl-gnupg-1.4.0-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+MY_P="${PN/pecl-/}-${PV/_rc/RC}"
+PHP_EXT_NAME="gnupg"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+PHP_EXT_PECL_FILENAME="${MY_P}.tgz"
+PHP_EXT_S="${WORKDIR}/${MY_P}"
+
+USE_PHP="php5-6 php7-0 php7-1 php7-2"
+
+inherit php-ext-pecl-r3
+
+S="${PHP_EXT_S}"
+
+KEYWORDS="~amd64 ~x86"
+DESCRIPTION="PHP wrapper around the gpgme library"
+LICENSE="BSD-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="app-crypt/gpgme app-crypt/gnupg"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/1.3.2/01-large_file_system.patch )
+
+# tests are broken with gnupg 2.0/2.1, see:
+# https://github.com/php-gnupg/php-gnupg/issues/2
+# https://github.com/php-gnupg/php-gnupg/issues/3
+RESTRICT="test"