summaryrefslogtreecommitdiff
path: root/dev-php/pecl-dio/pecl-dio-0.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-php/pecl-dio/pecl-dio-0.1.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-php/pecl-dio/pecl-dio-0.1.0.ebuild')
-rw-r--r--dev-php/pecl-dio/pecl-dio-0.1.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-php/pecl-dio/pecl-dio-0.1.0.ebuild b/dev-php/pecl-dio/pecl-dio-0.1.0.ebuild
new file mode 100644
index 000000000000..cf38fc0e688f
--- /dev/null
+++ b/dev-php/pecl-dio/pecl-dio-0.1.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PHP_EXT_NAME="dio"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+
+USE_PHP="php5-6 php7-0 php7-1"
+
+MY_PV=${PV/_rc/RC}
+PHP_EXT_S="${WORKDIR}/${PN/pecl-/}-${MY_PV}"
+
+inherit php-ext-pecl-r3
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Direct I/O functions for PHP"
+LICENSE="PHP-3.01"
+SLOT="0"
+IUSE=""
+
+S="${PHP_EXT_S}"