summaryrefslogtreecommitdiff
path: root/dev-php/pecl-crack/pecl-crack-0.4-r6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-php/pecl-crack/pecl-crack-0.4-r6.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-php/pecl-crack/pecl-crack-0.4-r6.ebuild')
-rw-r--r--dev-php/pecl-crack/pecl-crack-0.4-r6.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-php/pecl-crack/pecl-crack-0.4-r6.ebuild b/dev-php/pecl-crack/pecl-crack-0.4-r6.ebuild
new file mode 100644
index 000000000000..dcda4876842a
--- /dev/null
+++ b/dev-php/pecl-crack/pecl-crack-0.4-r6.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PHP_EXT_NAME="crack"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+PHP_EXT_EXTRA_ECONF=""
+DOCS=( EXPERIMENTAL )
+
+USE_PHP="php5-6 php7-0 php7-1"
+
+inherit php-ext-pecl-r3
+
+KEYWORDS="amd64 ppc ppc64 x86"
+
+DESCRIPTION="PHP interface to the cracklib libraries"
+LICENSE="PHP-3 CRACKLIB"
+SLOT="0"
+IUSE=""
+# Patch for http://pecl.php.net/bugs/bug.php?id=5765
+PATCHES=( "${FILESDIR}/fix-php-5-4-support.patch"
+"${FILESDIR}/fix-pecl-bug-5765.patch"
+"${FILESDIR}/${PV}-php7.patch"
+)