summaryrefslogtreecommitdiff
path: root/dev-php/pecl-apcu_bc/pecl-apcu_bc-1.0.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-10-22 11:09:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-10-22 11:09:47 +0100
commit64e107b9b6058580ff0432107eb37cefb0b2a7d8 (patch)
tree9a44e603e2ae365e2b1fe35ac37f73e830cdee1d /dev-php/pecl-apcu_bc/pecl-apcu_bc-1.0.4.ebuild
parent957235cf19a691360c720f7913672adda4258ed0 (diff)
gentoo resync : 22.10.2018
Diffstat (limited to 'dev-php/pecl-apcu_bc/pecl-apcu_bc-1.0.4.ebuild')
-rw-r--r--dev-php/pecl-apcu_bc/pecl-apcu_bc-1.0.4.ebuild25
1 files changed, 22 insertions, 3 deletions
diff --git a/dev-php/pecl-apcu_bc/pecl-apcu_bc-1.0.4.ebuild b/dev-php/pecl-apcu_bc/pecl-apcu_bc-1.0.4.ebuild
index 6cb699b96c74..0725748dbc35 100644
--- a/dev-php/pecl-apcu_bc/pecl-apcu_bc-1.0.4.ebuild
+++ b/dev-php/pecl-apcu_bc/pecl-apcu_bc-1.0.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -12,9 +12,9 @@ DOCS=( README.md )
USE_PHP="php7-0 php7-1 php7-2"
-inherit php-ext-pecl-r3
+inherit php-ext-pecl-r3 multilib
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="~amd64 x86"
DESCRIPTION="Provides APC backwards compatibility functions via APCu"
LICENSE="PHP-3.01"
@@ -23,3 +23,22 @@ IUSE=""
DEPEND="dev-php/pecl-apcu:7[php_targets_php7-0?,php_targets_php7-1?,php_targets_php7-2?]"
RDEPEND="${DEPEND}"
+
+src_test() {
+ # This fixed version is necessary to have apcu load
+ # from the install before the tested apc.
+ # It is intentional to specify phpoptions twice.
+ # This mimics the Makefile.
+ local slot phpoptions
+ for slot in $(php_get_slots); do
+ php_init_slot_env "${slot}"
+ ln -s "${EXT_DIR}/apcu$(get_libname)" \
+ "modules/" || die
+ phpoptions=( -n -d extension_dir="${PHP_EXT_S}/modules"
+ -d extension=apcu$(get_libname)
+ -d extension=apc$(get_libname) )
+ NO_INTERACTION="yes" TEST_PHP_EXECUTABLE="${PHPCLI}" \
+ "${PHPCLI}" "${phpoptions[@]}" \
+ run-tests.php "${phpoptions[@]}" || die
+ done
+}