summaryrefslogtreecommitdiff
path: root/dev-php/maxmind-db-reader
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-10-01 20:54:53 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-10-01 20:54:53 +0100
commit391b5b359a346aff490103da7dddc85047f83830 (patch)
tree29eea460a0bd7e1ff21d43b9d6df9af4d8a175e1 /dev-php/maxmind-db-reader
parentc719fdcee603a5a706a45d10cb598762d56a727d (diff)
gentoo resync : 01.10.2021
Diffstat (limited to 'dev-php/maxmind-db-reader')
-rw-r--r--dev-php/maxmind-db-reader/Manifest2
-rw-r--r--dev-php/maxmind-db-reader/maxmind-db-reader-1.10.1.ebuild78
2 files changed, 80 insertions, 0 deletions
diff --git a/dev-php/maxmind-db-reader/Manifest b/dev-php/maxmind-db-reader/Manifest
index b375223fd406..afea08292127 100644
--- a/dev-php/maxmind-db-reader/Manifest
+++ b/dev-php/maxmind-db-reader/Manifest
@@ -1,3 +1,5 @@
+DIST MaxMind-DB-Reader-php-1.10.1.tar.gz 23083 BLAKE2B f6684b07a184c4db7feebd9bf6b9afdc34c3de3b62bed59b2d01e1751eb996442d769576fbaa48e2bfa0572e80b2e0491d16d1cd9d89d35ca329e6dc17f74765 SHA512 841a03cf043ee0557e2157daee50d7f73211f5e665436eca8be6067d5357205093e40bb0402248fd6881d0d330feac96b298ec18763b8cb7d6d6392d54c59265
DIST MaxMind-DB-Reader-php-1.6.0.tar.gz 20898 BLAKE2B cf6922bbd5b2c76fcb9b7a97299f0a73232686bf8facce39355f8a4cc55e98a4d8e64a51eae8427b5f14d6905d4cd85956effa5299cc493bd63708cf52ab30d0 SHA512 e8c0ccf2cfcedf7527b4e3f858d2ed0e70add60692fff4a65f08e5cb885516b7c2a3ceaa3c21713369cd8ffca2b671d764063236de1d729cfc5173f7d5dd4607
+EBUILD maxmind-db-reader-1.10.1.ebuild 2218 BLAKE2B 53715ff00f7ecec725b560307356dc21fd4a129e4627395d2287b8d81bf9ac5d2c298bc677c05229c8fb12eaa4de5b6c4d18521457fdc176a1a6bdeb32258f85 SHA512 b0c330ccbd69d88f84629efa93d89400518d550a91b1e0b3dca55e9946d047943c7a3de023287a08e4e038d678d9577aa15269d1d448aa2918d9629078b97976
EBUILD maxmind-db-reader-1.6.0.ebuild 2218 BLAKE2B dca404bcaa496d72cce3bd8055728bdf5f69a6028dd9afeb3c358affa5636a745e36afa42a2eb505c96781bbc0d00535c4df197b4deffb899161a03b76fcd131 SHA512 8243d5a307ac4d3be45dc60c064a9285fbeafb74b847f75152863d9c97393f41b3268c7eec89725beae525435abfaa94a540a3ec04272b92136698050e4b7b54
MISC metadata.xml 586 BLAKE2B 69b8c42dc80e3b164f2287e0c65732ad0d5bc53ab1062e651dd85e21d5fdfb6a1e9990cd4d78077f2dcf73e2c8689e7be6a34c11cfd3ed8690a41a8a737e6246 SHA512 5604ac300486eaeb0bfd52d5a95438843b031eef15162438374e6126ace92327a64cb692a549d301f245fd6622856e973c9dbde60d2dcd398c667a9f8fa1fd5b
diff --git a/dev-php/maxmind-db-reader/maxmind-db-reader-1.10.1.ebuild b/dev-php/maxmind-db-reader/maxmind-db-reader-1.10.1.ebuild
new file mode 100644
index 000000000000..509cad6088ee
--- /dev/null
+++ b/dev-php/maxmind-db-reader/maxmind-db-reader-1.10.1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+MY_PN="MaxMind-DB-Reader-php"
+MY_P="${MY_PN}-${PV}"
+S="${WORKDIR}/${MY_P}"
+PHP_EXT_S="${S}/ext"
+PHP_EXT_NAME="maxminddb"
+PHP_EXT_OPTIONAL_USE="extension"
+
+USE_PHP="php7-3 php7-4 php8-0"
+
+inherit php-ext-source-r3
+
+DESCRIPTION="PHP reader for the MaxMind database format"
+HOMEPAGE="https://github.com/maxmind/MaxMind-DB-Reader-php"
+SRC_URI="https://github.com/maxmind/${MY_PN}/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="extension test"
+RESTRICT="!test? ( test )"
+
+DEPEND="extension? ( dev-libs/libmaxminddb )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # We need to call eapply_user ourselves, because it may be skipped
+ # if either the "extension" USE flag is not set, or if the user's
+ # PHP_TARGETS is essentially empty. In the latter case, the eclass
+ # src_prepare does nothing. We only call the eclass phase conditionally
+ # because the correct version of e.g. "phpize" may not be there
+ # unless USE=extension is set.
+ if use extension ; then
+ php-ext-source-r3_src_prepare
+ else
+ default
+ fi
+}
+
+src_configure() {
+ # The eclass phase will try to run the ./configure script even if it
+ # doesn't exist (in contrast to the default src_configure), so we
+ # need to skip it if the eclass src_prepare (that creates said
+ # script) is not run.
+ use extension && php-ext-source-r3_src_configure
+}
+
+src_compile() {
+ # Avoids the same problem as in src_configure.
+ use extension && php-ext-source-r3_src_compile
+}
+
+src_install() {
+ dodoc CHANGELOG.md README.md
+ insinto /usr/share/php
+ doins -r src/MaxMind
+ insinto /usr/share/php/MaxMind/Db
+ doins autoload.php
+
+ use extension && php-ext-source-r3_src_install
+}
+
+src_test() {
+ # The PHP API has its own set of tests that isn't shipped with the
+ # release tarballs at the moment (github issues 55).
+ use extension && php-ext-source-r3_src_test
+}
+
+pkg_postinst() {
+ elog "${PN} has been installed in /usr/share/php/MaxMind/Db/."
+ elog "To use it in a script, require('MaxMind/Db/autoload.php'),"
+ elog "and then most of the examples in the documentation should"
+ elog "work without further modification."
+}