summaryrefslogtreecommitdiff
path: root/dev-php/libvirt-php/libvirt-php-0.5.5-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-28 22:00:05 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-28 22:00:05 +0100
commit9c602d90d61cea9fe83c596c68a99e383ee15f73 (patch)
treebca80b41af9c142cee7e07f14622dff065e60932 /dev-php/libvirt-php/libvirt-php-0.5.5-r1.ebuild
parentcf7630078a53ff74b245b148bd722994068e28f9 (diff)
gentoo auto-resync : 28:10:2022 - 22:00:04
Diffstat (limited to 'dev-php/libvirt-php/libvirt-php-0.5.5-r1.ebuild')
-rw-r--r--dev-php/libvirt-php/libvirt-php-0.5.5-r1.ebuild74
1 files changed, 0 insertions, 74 deletions
diff --git a/dev-php/libvirt-php/libvirt-php-0.5.5-r1.ebuild b/dev-php/libvirt-php/libvirt-php-0.5.5-r1.ebuild
deleted file mode 100644
index 57415a26ee3c..000000000000
--- a/dev-php/libvirt-php/libvirt-php-0.5.5-r1.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-PHP_EXT_NAME="libvirt-php"
-PHP_EXT_SKIP_PHPIZE="yes"
-USE_PHP="php7-4"
-PHP_EXT_ECONF_ARGS=()
-
-inherit php-ext-source-r3 autotools flag-o-matic
-
-DESCRIPTION="PHP bindings for libvirt"
-HOMEPAGE="http://libvirt.org/php/"
-SRC_URI="http://libvirt.org/sources/php/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="doc"
-
-RDEPEND="app-emulation/libvirt
- dev-libs/libxml2"
-DEPEND="${RDEPEND}
- dev-libs/libxslt
- virtual/pkgconfig
- doc? ( app-text/xhtml1 )"
-
-RESTRICT="test"
-# ChangeLog and NEWS are empty files
-DOCS=( AUTHORS README )
-# Remove the insane check for pecl-imagick which is only used in examples
-# and is not called upon in any build
-PATCHES=( "${FILESDIR}/remove-imagick-check.patch" )
-
-src_unpack() {
- default
-
- # create the default modules directory to be able
- # to use the php-ext-source-r3 eclass to configure/build
- ln -s src "${S}/modules"
-}
-
-src_prepare() {
- php-ext-source-r3_src_prepare
-
- local slot
- for slot in $(php_get_slots); do
- php_init_slot_env "${slot}"
- eautoreconf
- done
-}
-
-src_configure() {
- append-cflags -fcommon
- php-ext-source-r3_src_configure
-}
-
-src_install() {
- local slot
- for slot in $(php_get_slots); do
- php_init_slot_env ${slot}
- insinto "${EXT_DIR}"
- doins "src/.libs/${PHP_EXT_NAME}.so"
- done
-
- php-ext-source-r3_createinifiles
- einstalldocs
-
- if use doc ; then
- docinto html
- dodoc -r docs/*
- fi
-}