summaryrefslogtreecommitdiff
path: root/dev-php/igbinary/igbinary-3.2.9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-26 21:56:23 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-26 21:56:23 +0100
commit97e5ac8a082d0d11fc18e8b8994a78e8d155899e (patch)
treedab08cf04e891e90970759f697657a399cf9990f /dev-php/igbinary/igbinary-3.2.9.ebuild
parent533ce9c954925ca2a6bccd1f52f266e81e61a678 (diff)
gentoo auto-resync : 26:10:2022 - 21:56:23
Diffstat (limited to 'dev-php/igbinary/igbinary-3.2.9.ebuild')
-rw-r--r--dev-php/igbinary/igbinary-3.2.9.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-php/igbinary/igbinary-3.2.9.ebuild b/dev-php/igbinary/igbinary-3.2.9.ebuild
new file mode 100644
index 000000000000..b2f81fe8a0fa
--- /dev/null
+++ b/dev-php/igbinary/igbinary-3.2.9.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PHP_EXT_ECONF_ARGS=( --enable-${PN} )
+PHP_EXT_INI="yes"
+PHP_EXT_NAME="${PN}"
+PHP_EXT_ZENDEXT="no"
+USE_PHP="php7-4 php8-0 php8-1 php8-2"
+
+inherit php-ext-source-r3
+
+DESCRIPTION="A fast drop-in replacement for the standard PHP serialize"
+HOMEPAGE="https://github.com/igbinary/igbinary"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"