summaryrefslogtreecommitdiff
path: root/dev-php/igbinary/igbinary-3.2.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /dev-php/igbinary/igbinary-3.2.2.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'dev-php/igbinary/igbinary-3.2.2.ebuild')
-rw-r--r--dev-php/igbinary/igbinary-3.2.2.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-php/igbinary/igbinary-3.2.2.ebuild b/dev-php/igbinary/igbinary-3.2.2.ebuild
new file mode 100644
index 000000000000..a4b536d340b9
--- /dev/null
+++ b/dev-php/igbinary/igbinary-3.2.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PHP_EXT_NAME="${PN}"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS=( CREDITS NEWS README.md )
+PHP_EXT_ECONF_ARGS=( --enable-${PN} )
+
+USE_PHP="php7-3 php7-4 php8-0"
+
+inherit php-ext-source-r3
+
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+DESCRIPTION="A fast drop-in replacement for the standard PHP serialize"
+HOMEPAGE="https://github.com/igbinary/igbinary"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"