summaryrefslogtreecommitdiff
path: root/dev-php/cphplib/cphplib-0.51-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-php/cphplib/cphplib-0.51-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-php/cphplib/cphplib-0.51-r1.ebuild')
-rw-r--r--dev-php/cphplib/cphplib-0.51-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-php/cphplib/cphplib-0.51-r1.ebuild b/dev-php/cphplib/cphplib-0.51-r1.ebuild
new file mode 100644
index 000000000000..c79a4a612094
--- /dev/null
+++ b/dev-php/cphplib/cphplib-0.51-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Cute PHP Library (cphplib)"
+HOMEPAGE="http://cphplib.sourceforge.net/"
+SRC_URI="mirror://sourceforge/cphplib/${P}.tar.bz2"
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="doc"
+
+DEPEND=">=dev-php/PEAR-DB-1.7.6-r1"
+RDEPEND="${DEPEND}"
+PATCHES=( "${FILESDIR}/constructor.patch" )
+
+src_install() {
+ local DOCS=( ChangeLog README TODO )
+ local -a HTML_DOCS
+ insinto "/usr/share/php/${PN}"
+ doins -r i18n cphplib_formular.inc cphplib.inc
+ use doc && HTML_DOCS=( doc/packages.html doc/blank.html
+ doc/classtrees_cphplib.html doc/index.html doc/cphplib/
+ doc/errors.html doc/__filesource/ doc/elementindex.html
+ doc/li_cphplib.html doc/elementindex_cphplib.html doc/media/ )
+ einstalldocs
+}