summaryrefslogtreecommitdiff
path: root/dev-php/SabreAMF/SabreAMF-1.5.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-11-03 08:36:22 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-11-03 08:36:22 +0000
commitf65628136faa35d0c4d3b5e7332275c7b35fcd96 (patch)
tree021998302365c5652e37824b6c26d4d969a62055 /dev-php/SabreAMF/SabreAMF-1.5.0.ebuild
parent70b82ae359a5538711e103b0e8dfb92654296644 (diff)
gentoo resync : 03.11.2018
Diffstat (limited to 'dev-php/SabreAMF/SabreAMF-1.5.0.ebuild')
-rw-r--r--dev-php/SabreAMF/SabreAMF-1.5.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-php/SabreAMF/SabreAMF-1.5.0.ebuild b/dev-php/SabreAMF/SabreAMF-1.5.0.ebuild
new file mode 100644
index 000000000000..ce985ece45a7
--- /dev/null
+++ b/dev-php/SabreAMF/SabreAMF-1.5.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="SabreAMF is a Flash Remoting server and client for PHP"
+HOMEPAGE="https://github.com/evert/SabreAMF"
+SRC_URI="https://github.com/evert/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="examples"
+
+RDEPEND="dev-php/fedora-autoloader"
+
+DOCS=( README.md ChangeLog )
+
+src_install() {
+ insinto /usr/share/php/${PN}
+ doins -r lib/${PN}/* "${FILESDIR}/autoload.php"
+ einstalldocs
+ if use examples ; then
+ insinto /usr/share/doc/${P}/examples
+ docompress -x /usr/share/doc/${P}/examples
+ doins examples/*
+ fi
+}