summaryrefslogtreecommitdiff
path: root/dev-php/PHP_Timer/PHP_Timer-5.0.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-07 22:48:01 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-07 22:48:01 +0000
commitc3bc61051d7f12b4c682efa7a5460bbc8815649e (patch)
treeb6d19e96ba3c397fb8278eeb9b68170db92630ba /dev-php/PHP_Timer/PHP_Timer-5.0.3.ebuild
parent3517852e3b8a68d1e997770fc0650c5053bafc6c (diff)
gentoo resync : 07.01.2022
Diffstat (limited to 'dev-php/PHP_Timer/PHP_Timer-5.0.3.ebuild')
-rw-r--r--dev-php/PHP_Timer/PHP_Timer-5.0.3.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-php/PHP_Timer/PHP_Timer-5.0.3.ebuild b/dev-php/PHP_Timer/PHP_Timer-5.0.3.ebuild
new file mode 100644
index 000000000000..411c705df558
--- /dev/null
+++ b/dev-php/PHP_Timer/PHP_Timer-5.0.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN="php-timer"
+
+DESCRIPTION="Utility class for timing"
+HOMEPAGE="https://phpunit.de"
+SRC_URI="https://github.com/sebastianbergmann/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+RDEPEND="dev-php/fedora-autoloader
+ >=dev-lang/php-7.3:*"
+
+src_install() {
+ insinto /usr/share/php/PHP/Timer
+ doins -r src/*
+ newins "${FILESDIR}/autoload-5.0.3.php" autoload.php
+}
+
+pkg_postinst() {
+ ewarn "This library now loads via /usr/share/php/PHP/Timer/autoload.php"
+ ewarn "Please update any scripts to require the autoloader"
+}