summaryrefslogtreecommitdiff
path: root/dev-php/PEAR-XML_Parser
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
commit2fd57282f0262ca084e05b0f2c63fbada395d02b (patch)
tree4e0f23cea9ce9fd972e70ebc5214bf36fed465cc /dev-php/PEAR-XML_Parser
parentc3bc61051d7f12b4c682efa7a5460bbc8815649e (diff)
gentoo resync : 16.01.2021
Diffstat (limited to 'dev-php/PEAR-XML_Parser')
-rw-r--r--dev-php/PEAR-XML_Parser/Manifest2
-rw-r--r--dev-php/PEAR-XML_Parser/PEAR-XML_Parser-1.3.8-r1.ebuild29
-rw-r--r--dev-php/PEAR-XML_Parser/files/XML_Parser-1.3.8-php8.patch66
3 files changed, 97 insertions, 0 deletions
diff --git a/dev-php/PEAR-XML_Parser/Manifest b/dev-php/PEAR-XML_Parser/Manifest
index 82acc30cff8a..ca152aac1066 100644
--- a/dev-php/PEAR-XML_Parser/Manifest
+++ b/dev-php/PEAR-XML_Parser/Manifest
@@ -1,5 +1,7 @@
+AUX XML_Parser-1.3.8-php8.patch 2326 BLAKE2B eea8733bfbb1e36ff64ac666b7d52fc7f5b0770dd8c99c6fc25daa3f1e480faa86d786e88593aac791c11e1500b0f560b819438ac13760f1066097bc74c597f0 SHA512 46f1ff5d882901ff761a940276c9e54e4050091f786935eaf93d775073b6c02cf3d8659024b97a196f653ecd2f160eadaed42c10ebe30ded3ae42b502a100255
DIST XML_Parser-1.3.7.tgz 13339 BLAKE2B 10cc89dbf4f6c4b28fea73cc45757e71a897b01fd21a3d2711fef5eb0cd33e1fdeda143ce88dd425fdea9802a02f3d7e352ec17295b88d8cfae87af6a342f622 SHA512 b4e6c76962eb47f15096e7d77658cf41ca372a9389967e5204e865b253da4f4e248e7b893aa4c6624bb1178e3985667d018849df6d9a07aa6b9a707c743fe64b
DIST XML_Parser-1.3.8.tgz 13534 BLAKE2B c0227d48b43b9b0fec3251c81e56017344101b4a2dc9a5eb85310d1130148a1d7e365b3b6e3f4fcab03aeac1f702f81f22d45c4db67ff515836ef8a173cd7d4c SHA512 f840acf2e068d642177d37958487021b5bf57cd33048738f2f18fa35d83dfe428ce327900a9a141c2a184e4dbdddc9e8eefaf87604131f516f016aee30aad603
EBUILD PEAR-XML_Parser-1.3.7-r1.ebuild 335 BLAKE2B 8d0a94831080a1b63f6d027f0bc8116e4ab060a7d006c845988b741cd3bdd632413506e6d6c27a5600c4a576e787560c44cdfd3556b16ccb8aa6bac044f4a747 SHA512 c92564e9843a44010860df1d75742d0ee0b268dd691a5f58f56042add9ef1d05fc48e246f43ed969b125c02e1640dbc46d70848511c82db0ac1378de231c1e9f
+EBUILD PEAR-XML_Parser-1.3.8-r1.ebuild 798 BLAKE2B 93297c78f0f949d872fe7e9aadeead3ac6d211b172b5b403544d2b8b827d9a16ca64295a75e56b702da9a23a550903eaad3acdf7e9b1bdc70b1df2b0f72b1762 SHA512 ee751f12cc4c2b5481d032ae70819065b90265152611ee5239a5e6a48e240c2243757a446d59babb1d35ff82e5dc6efcb0772422879f3e70b4552b576c1cb182
EBUILD PEAR-XML_Parser-1.3.8.ebuild 341 BLAKE2B dc7dd85a9ce752a957097bc131fcc7ac565139ebb5f693d8731a2f191ba20e3e17ba9a72cfbf024eb86f8858497b9fb23a3eff58e7b174ca89d7c7c47667d19a SHA512 7ea194eca487b19e8d95f3c182fe3dca4e3a07bcac0758c6e2bcafea7774bddc3cd1c362157b6ce6249f79e97aa7ebecf02286453a481bf435cc94ecee16065c
MISC metadata.xml 236 BLAKE2B 55612da78a71f8cee31c387a5862636996734210d765fac66d8c7706acc5151e6a9e7ff5123aeb097c911495c6220ba3b5d2f1355f46e8ab6bdb240e1697e26d SHA512 2782b20a65dca663ff7c64b7e67db05641abed478fd5996e5750b2e52ba870829f89125baa8967dd29fd20ef9b46ad233b0dd08801308b7756717ec2f292446c
diff --git a/dev-php/PEAR-XML_Parser/PEAR-XML_Parser-1.3.8-r1.ebuild b/dev-php/PEAR-XML_Parser/PEAR-XML_Parser-1.3.8-r1.ebuild
new file mode 100644
index 000000000000..461ae05c1155
--- /dev/null
+++ b/dev-php/PEAR-XML_Parser/PEAR-XML_Parser-1.3.8-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit php-pear-r2
+
+DESCRIPTION="XML parsing class based on PHP's SAX parser"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+# This is to match patch compatibility
+RDEPEND="!<dev-php/PEAR-XML_RSS-1.1.0-r2"
+
+PATCHES=( "${FILESDIR}/XML_Parser-1.3.8-php8.patch" )
+
+src_test() {
+ peardev run-tests -r || die
+}
+
+pkg_postinst() {
+ php-pear-r2_pkg_postinst
+ elog 'This version includes a PHP 8 compatibilty patch for startHandler'
+ elog 'which removes the pass-by-reference off of $attribs (third parameter).'
+ elog 'This could break old scripts with recent versions until that override also'
+ elog 'removes the pass-by-reference.'
+}
diff --git a/dev-php/PEAR-XML_Parser/files/XML_Parser-1.3.8-php8.patch b/dev-php/PEAR-XML_Parser/files/XML_Parser-1.3.8-php8.patch
new file mode 100644
index 000000000000..8115fd8d7297
--- /dev/null
+++ b/dev-php/PEAR-XML_Parser/files/XML_Parser-1.3.8-php8.patch
@@ -0,0 +1,66 @@
+diff -aruN a/XML/Parser.php b/XML/Parser.php
+--- a/XML/Parser.php 2022-01-10 11:32:08.624378884 -0500
++++ b/XML/Parser.php 2022-01-10 11:47:09.581396869 -0500
+@@ -651,12 +651,12 @@
+ *
+ * @param mixed $xp ??
+ * @param mixed $elem ??
+- * @param mixed &$attribs ??
++ * @param mixed $attribs ??
+ *
+ * @return null
+ * @abstract
+ */
+- function startHandler($xp, $elem, &$attribs)
++ function startHandler($xp, $elem, $attribs)
+ {
+ return null;
+ }
+diff -aruN a/tests/001.phpt b/tests/001.phpt
+--- a/tests/001.phpt 2019-04-10 14:18:52.000000000 -0400
++++ b/tests/001.phpt 2022-01-10 11:46:50.341458673 -0500
+@@ -13,10 +13,10 @@
+ require_once "XML/Parser.php";
+
+ class __TestParser1 extends XML_Parser {
+- function startHandler($xp, $element, &$attribs) {
++ function startHandler($xp, $element, $attribs) {
+ print "<$element";
+ reset($attribs);
+- while (list($key, $val) = each($attribs)) {
++ foreach ($attribs as $key => $val) {
+ $enc = htmlentities($val);
+ print " $key=\"$enc\"";
+ }
+diff -aruN /tests/002.phpt /tests/002.phpt
+--- a/tests/002.phpt 2019-04-10 14:18:52.000000000 -0400
++++ b/tests/002.phpt 2022-01-10 11:46:58.281433169 -0500
+@@ -13,10 +13,10 @@
+ require_once "XML/Parser.php";
+
+ class __TestParser2 extends XML_Parser {
+- function startHandler($xp, $element, &$attribs) {
++ function startHandler($xp, $element, $attribs) {
+ print "<$element";
+ reset($attribs);
+- while (list($key, $val) = each($attribs)) {
++ foreach ($attribs as $key => $val) {
+ $enc = htmlentities($val);
+ print " $key=\"$enc\"";
+ }
+diff -aruN /tests/003.phpt /tests/003.phpt
+--- a/tests/003.phpt 2019-04-10 14:18:52.000000000 -0400
++++ b/tests/003.phpt 2022-01-10 11:41:03.402573127 -0500
+@@ -13,10 +13,10 @@
+ require_once "XML/Parser.php";
+
+ class __TestParser3 extends XML_Parser {
+- function startHandler($xp, $element, &$attribs) {
++ function startHandler($xp, $element, $attribs) {
+ print "<$element";
+ reset($attribs);
+- while (list($key, $val) = each($attribs)) {
++ foreach ($attribs as $key => $val) {
+ $enc = htmlentities($val);
+ print " $key=\"$enc\"";
+ }