summaryrefslogtreecommitdiff
path: root/dev-php/PEAR-Var_Dump/PEAR-Var_Dump-1.0.4-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-php/PEAR-Var_Dump/PEAR-Var_Dump-1.0.4-r3.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-php/PEAR-Var_Dump/PEAR-Var_Dump-1.0.4-r3.ebuild')
-rw-r--r--dev-php/PEAR-Var_Dump/PEAR-Var_Dump-1.0.4-r3.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-php/PEAR-Var_Dump/PEAR-Var_Dump-1.0.4-r3.ebuild b/dev-php/PEAR-Var_Dump/PEAR-Var_Dump-1.0.4-r3.ebuild
new file mode 100644
index 000000000000..707cff167f52
--- /dev/null
+++ b/dev-php/PEAR-Var_Dump/PEAR-Var_Dump-1.0.4-r3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit php-pear-r2
+
+DESCRIPTION="Dump structured information about a variable"
+LICENSE="PHP-3.01"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="examples test"
+
+DEPEND="test? ( dev-php/PEAR-PEAR )"
+
+# The test suite fails due to some deprecation warnings that are output.
+# The test cases themselves set error_reporting(E_ALL), so there's no
+# easy way to override it.
+RESTRICT=test
+
+src_install() {
+ use examples && dodoc -r docs/example*.php
+ php-pear-r2_src_install
+}
+
+src_test() {
+ # Requires the "pear" executable from dev-php/PEAR-PEAR.
+ pear run-tests tests || die
+
+ # The command succeeds regardless of whether or not the test suite
+ # passed, but this file is only written when there was a failure.
+ [[ -f run-tests.log ]] && die "test suite failed"
+}