summaryrefslogtreecommitdiff
path: root/dev-php/PEAR-Text_Password/PEAR-Text_Password-1.2.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-php/PEAR-Text_Password/PEAR-Text_Password-1.2.1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-php/PEAR-Text_Password/PEAR-Text_Password-1.2.1.ebuild')
-rw-r--r--dev-php/PEAR-Text_Password/PEAR-Text_Password-1.2.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-php/PEAR-Text_Password/PEAR-Text_Password-1.2.1.ebuild b/dev-php/PEAR-Text_Password/PEAR-Text_Password-1.2.1.ebuild
new file mode 100644
index 000000000000..3ba8e34522fd
--- /dev/null
+++ b/dev-php/PEAR-Text_Password/PEAR-Text_Password-1.2.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="${PN/PEAR-/}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Creating passwords with PHP"
+HOMEPAGE="http://pear.php.net/package/${MY_PN}"
+SRC_URI="http://download.pear.php.net/package/${MY_P}.tgz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 ~sparc x86"
+IUSE="test"
+
+RDEPEND="dev-lang/php:*"
+DEPEND="test? ( ${RDEPEND} dev-php/phpunit )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ insinto /usr/share/php
+ doins -r Text
+}
+
+src_test() {
+ phpunit tests/ || die 'test suite failed'
+}