summaryrefslogtreecommitdiff
path: root/dev-php/PEAR-Text_Highlighter/PEAR-Text_Highlighter-0.7.3-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-php/PEAR-Text_Highlighter/PEAR-Text_Highlighter-0.7.3-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-php/PEAR-Text_Highlighter/PEAR-Text_Highlighter-0.7.3-r1.ebuild')
-rw-r--r--dev-php/PEAR-Text_Highlighter/PEAR-Text_Highlighter-0.7.3-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-php/PEAR-Text_Highlighter/PEAR-Text_Highlighter-0.7.3-r1.ebuild b/dev-php/PEAR-Text_Highlighter/PEAR-Text_Highlighter-0.7.3-r1.ebuild
new file mode 100644
index 000000000000..4ddca264aecd
--- /dev/null
+++ b/dev-php/PEAR-Text_Highlighter/PEAR-Text_Highlighter-0.7.3-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="${PN/PEAR-/}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A package for syntax highlighting"
+HOMEPAGE="http://pear.php.net/package/${MY_PN}"
+SRC_URI="http://download.pear.php.net/package/${MY_P}.tgz"
+LICENSE="PHP-3.01"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# There is a documented dependency on XML_Parser, but that's only needed
+# for development -- if you want to *generate* the PHP class files. The
+# ones in the release are already pre-generated. The dependency on the
+# XML_Serializer, on the other hand, is not documented but is requird
+# by the XML output renderer.
+RDEPEND="dev-lang/php
+ dev-php/PEAR-PEAR
+ dev-php/PEAR-XML_Serializer"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ dodoc README TODO
+
+ insinto /usr/share/php
+ doins -r Text
+}