summaryrefslogtreecommitdiff
path: root/dev-php/PEAR-Net_SmartIRC/PEAR-Net_SmartIRC-1.1.14.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-06 10:28:05 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-06 10:28:05 +0100
commitf1af93971b7490792d8541bc790e0d8c6d787059 (patch)
treea38046712bbc3a3844d77452d16c84e716caa3d4 /dev-php/PEAR-Net_SmartIRC/PEAR-Net_SmartIRC-1.1.14.ebuild
parentfc637fb28da700da71ec2064d65ca5a7a31b9c6c (diff)
gentoo resync : 06.08.2019
Diffstat (limited to 'dev-php/PEAR-Net_SmartIRC/PEAR-Net_SmartIRC-1.1.14.ebuild')
-rw-r--r--dev-php/PEAR-Net_SmartIRC/PEAR-Net_SmartIRC-1.1.14.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-php/PEAR-Net_SmartIRC/PEAR-Net_SmartIRC-1.1.14.ebuild b/dev-php/PEAR-Net_SmartIRC/PEAR-Net_SmartIRC-1.1.14.ebuild
new file mode 100644
index 000000000000..c6e49dbd4c32
--- /dev/null
+++ b/dev-php/PEAR-Net_SmartIRC/PEAR-Net_SmartIRC-1.1.14.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit php-pear-r2
+
+DESCRIPTION="PHP class to communicate with IRC networks"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc examples"
+DOCS=( CREDITS FEATURES docs/HOWTO README.md )
+
+src_install() {
+ local HTML_DOCS=( )
+ use examples && HTML_DOCS+=( docs/examples/ )
+
+ if use doc; then
+ DOCS+=( docs/DOCUMENTATION )
+ HTML_DOCS+=( docs/HTML/* )
+ fi
+ php-pear-r2_src_install
+}