summaryrefslogtreecommitdiff
path: root/dev-php/PEAR-Mail_mimeDecode/PEAR-Mail_mimeDecode-1.5.6-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-php/PEAR-Mail_mimeDecode/PEAR-Mail_mimeDecode-1.5.6-r3.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-php/PEAR-Mail_mimeDecode/PEAR-Mail_mimeDecode-1.5.6-r3.ebuild')
-rw-r--r--dev-php/PEAR-Mail_mimeDecode/PEAR-Mail_mimeDecode-1.5.6-r3.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-php/PEAR-Mail_mimeDecode/PEAR-Mail_mimeDecode-1.5.6-r3.ebuild b/dev-php/PEAR-Mail_mimeDecode/PEAR-Mail_mimeDecode-1.5.6-r3.ebuild
new file mode 100644
index 000000000000..56773b569a82
--- /dev/null
+++ b/dev-php/PEAR-Mail_mimeDecode/PEAR-Mail_mimeDecode-1.5.6-r3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit php-pear-r2
+
+DESCRIPTION="Provides a class to decode mime messages (split from PEAR-Mail_Mime)"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm ~hppa ~ia64 ppc ppc64 ~s390 sparc x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=dev-php/PEAR-Mail_Mime-1.5.2"
+DEPEND="test? ( ${RDEPEND} dev-php/PEAR-PEAR )"
+
+PATCHES=(
+ "${FILESDIR}/PEAR-Mail_mimeDecode-1.5.6-r3-php8_compat.patch"
+)
+
+src_test() {
+ pear run-tests tests || die
+}