summaryrefslogtreecommitdiff
path: root/dev-php/PEAR-Log/PEAR-Log-1.13.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-26 21:58:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-26 21:58:12 +0100
commitd76b6613e545057331e9273ddd21e68d28d9e402 (patch)
tree2823b704acff0caa2bf185b4e4b38c95731cba39 /dev-php/PEAR-Log/PEAR-Log-1.13.2.ebuild
parentf6fd15e0418aea97c7ee77672468561cdac302e5 (diff)
gentoo auto-resync : 26:08:2023 - 21:58:11
Diffstat (limited to 'dev-php/PEAR-Log/PEAR-Log-1.13.2.ebuild')
-rw-r--r--dev-php/PEAR-Log/PEAR-Log-1.13.2.ebuild48
1 files changed, 0 insertions, 48 deletions
diff --git a/dev-php/PEAR-Log/PEAR-Log-1.13.2.ebuild b/dev-php/PEAR-Log/PEAR-Log-1.13.2.ebuild
deleted file mode 100644
index 384c2311aa5c..000000000000
--- a/dev-php/PEAR-Log/PEAR-Log-1.13.2.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-MY_PN="${PN/PEAR-/}"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="The Log framework provides an abstracted logging system"
-HOMEPAGE="https://pear.php.net/package/Log"
-SRC_URI="http://download.pear.php.net/package/${MY_P}.tgz"
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
-IUSE="examples test"
-RESTRICT="!test? ( test )"
-
-# The DB, Mail, and MDB2 dependencies are technically optional, but
-# automagic. To avoid surprises, we require them unconditionally.
-RDEPEND="dev-lang/php:*
- dev-php/PEAR-PEAR
- dev-php/PEAR-DB
- dev-php/PEAR-Mail
- dev-php/PEAR-MDB2"
-DEPEND="test? ( ${RDEPEND} )"
-
-S="${WORKDIR}/${MY_P}"
-
-src_install() {
- dodoc docs/guide.txt misc/log.sql
- use examples && dodoc -r examples
-
- # I don't like installing "Log.php" right at the top-level, but any
- # packages depending on us will expect to find it there and not as
- # e.g. Log/Log.php.
- insinto "/usr/share/php/"
- doins Log.php
- doins -r Log
-}
-
-src_test() {
- # Requires the "pear" executable from dev-php/PEAR-PEAR.
- pear run-tests tests || die
-
- # The command succeeds regardless of whether or not the test suite
- # passed, but this file is only written when there was a failure.
- [[ -f run-tests.log ]] && die "test suite failed"
-}