summaryrefslogtreecommitdiff
path: root/dev-php/PEAR-File_Gettext
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-php/PEAR-File_Gettext
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-php/PEAR-File_Gettext')
-rw-r--r--dev-php/PEAR-File_Gettext/Manifest4
-rw-r--r--dev-php/PEAR-File_Gettext/PEAR-File_Gettext-0.4.2-r1.ebuild14
-rw-r--r--dev-php/PEAR-File_Gettext/files/File_Gettext-0.4.2-construct.patch67
-rw-r--r--dev-php/PEAR-File_Gettext/metadata.xml8
4 files changed, 93 insertions, 0 deletions
diff --git a/dev-php/PEAR-File_Gettext/Manifest b/dev-php/PEAR-File_Gettext/Manifest
new file mode 100644
index 000000000000..76d7d72d0710
--- /dev/null
+++ b/dev-php/PEAR-File_Gettext/Manifest
@@ -0,0 +1,4 @@
+AUX File_Gettext-0.4.2-construct.patch 1999 BLAKE2B 5feac1b3c48fef5401158a06db1410878b50d28841807ea5d2f99c7c59cc51472927f9ee85f9b29deadfbe0c964f761d2fbdcfd912ceeda6a722f463370373ff SHA512 a1ca97160f3c521ba340a89c19933daba20b0c11716349b34b330fe10f5a9e924cc28fa7248efb64648ef1ffac832a16c6051723d6f76c63a03454a523a9fe6e
+DIST File_Gettext-0.4.2.tgz 7307 BLAKE2B f1eae4724c62a44515107a0e4cb89aa7abff8f856c5f11a90f6b78dc4e5601cc024e64e8ae0344c3433ffc5355e2dbb9d7e3cc745001ad2098a073bbca0a97da SHA512 cc56430076485d90afca548c78650a2ada4eb8df7e0a58458eded2dca222466aba91d982fb0103e6b63fc4c8140c3ac4c2a4a7c3c77fbc7740922a8b4e33c6a9
+EBUILD PEAR-File_Gettext-0.4.2-r1.ebuild 338 BLAKE2B 2c1019e66b1d882a149c27c7ca77d2e3850ff2da4cde9544162310e68e7cff3f24733c03fea3a35651edf1441593dc76b3d8c71792d4fe8e36fc463e38e0f9c4 SHA512 638688b767d165d864a512f846a1823f55c6cb18b8dd6153135d391232c453b8f32d94551dfcfb6a6edc10220cfdf0d67ce9d50f9621ab88257eb1e94af9299a
+MISC metadata.xml 239 BLAKE2B 9b7c5dcb74289073481cf07031b7a92f32496cc1097becb074d74a8fbb8133de429ce1baf284e446e44132943c8b32e6b824570f15828588e42ea49ef5661f00 SHA512 2181b874bfe8cd31e7730d8207e26cfd2f272eaf2d1b57ae0faff126347a5298fa1c506d9107e1da9736c8a0ed9c8c339e4d9509a8726b79dbe86e073c12dee0
diff --git a/dev-php/PEAR-File_Gettext/PEAR-File_Gettext-0.4.2-r1.ebuild b/dev-php/PEAR-File_Gettext/PEAR-File_Gettext-0.4.2-r1.ebuild
new file mode 100644
index 000000000000..633c8c657fc4
--- /dev/null
+++ b/dev-php/PEAR-File_Gettext/PEAR-File_Gettext-0.4.2-r1.ebuild
@@ -0,0 +1,14 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit php-pear-r2
+
+DESCRIPTION="GNU Gettext file parser"
+
+LICENSE="PHP-3"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm hppa ia64 ppc ppc64 ~s390 ~sh sparc x86"
+IUSE=""
+PATCHES=( "${FILESDIR/File_Gettext-0.4.2-construct.patch}" )
diff --git a/dev-php/PEAR-File_Gettext/files/File_Gettext-0.4.2-construct.patch b/dev-php/PEAR-File_Gettext/files/File_Gettext-0.4.2-construct.patch
new file mode 100644
index 000000000000..3527814485ab
--- /dev/null
+++ b/dev-php/PEAR-File_Gettext/files/File_Gettext-0.4.2-construct.patch
@@ -0,0 +1,67 @@
+diff -aurN a/File/Gettext/MO.php b/File/Gettext/MO.php
+--- a/File/Gettext/MO.php 2012-03-03 22:00:49.000000000 -0500
++++ b/File/Gettext/MO.php 2018-02-16 15:15:17.725027132 -0500
+@@ -60,6 +60,10 @@
+ * @access public
+ * @return object File_Gettext_MO
+ */
++ function __construct($file = '')
++ {
++ $this->file = $file;
++ }
+ function File_Gettext_MO($file = '')
+ {
+ $this->file = $file;
+diff -aurN a/File/Gettext/PO.php b/File/Gettext/PO.php
+--- a/File/Gettext/PO.php 2012-03-03 22:00:49.000000000 -0500
++++ b/File/Gettext/PO.php 2018-02-16 15:14:57.997419162 -0500
+@@ -42,6 +42,10 @@
+ * @access public
+ * @return object File_Gettext_PO
+ */
++ function __construct($file = '')
++ {
++ $this->file = $file;
++ }
+ function File_Gettext_PO($file = '')
+ {
+ $this->file = $file;
+diff -aurN a/File/Gettext.php b/File/Gettext.php
+--- a/File/Gettext.php 2012-03-03 22:00:49.000000000 -0500
++++ b/File/Gettext.php 2018-02-16 15:14:27.629022634 -0500
+@@ -85,7 +85,7 @@
+ return File_Gettext::raiseError($php_errormsg);
+ }
+ $class = 'File_Gettext_' . $format;
+- $obref = &new $class($file);
++ $obref = new $class($file);
+ return $obref;
+ }
+
+@@ -110,7 +110,7 @@
+
+ include_once 'File/Gettext/PO.php';
+
+- $PO = &new File_Gettext_PO($pofile);
++ $PO = new File_Gettext_PO($pofile);
+ if (true !== ($e = $PO->load())) {
+ return $e;
+ }
+@@ -247,7 +247,7 @@
+ function &toMO()
+ {
+ include_once 'File/Gettext/MO.php';
+- $MO = &new File_Gettext_MO;
++ $MO = new File_Gettext_MO;
+ $MO->fromArray($this->toArray());
+ return $MO;
+ }
+@@ -261,7 +261,7 @@
+ function &toPO()
+ {
+ include_once 'File/Gettext/PO.php';
+- $PO = &new File_Gettext_PO;
++ $PO = new File_Gettext_PO;
+ $PO->fromArray($this->toArray());
+ return $PO;
+ }
diff --git a/dev-php/PEAR-File_Gettext/metadata.xml b/dev-php/PEAR-File_Gettext/metadata.xml
new file mode 100644
index 000000000000..b86acf66c756
--- /dev/null
+++ b/dev-php/PEAR-File_Gettext/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>php-bugs@gentoo.org</email>
+ <name>PHP</name>
+ </maintainer>
+</pkgmetadata>