summaryrefslogtreecommitdiff
path: root/dev-php/PEAR-File_Archive/PEAR-File_Archive-1.5.5-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-php/PEAR-File_Archive/PEAR-File_Archive-1.5.5-r1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-php/PEAR-File_Archive/PEAR-File_Archive-1.5.5-r1.ebuild')
-rw-r--r--dev-php/PEAR-File_Archive/PEAR-File_Archive-1.5.5-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-php/PEAR-File_Archive/PEAR-File_Archive-1.5.5-r1.ebuild b/dev-php/PEAR-File_Archive/PEAR-File_Archive-1.5.5-r1.ebuild
new file mode 100644
index 000000000000..ae8e9667a517
--- /dev/null
+++ b/dev-php/PEAR-File_Archive/PEAR-File_Archive-1.5.5-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="${PN/PEAR-/}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Easily manipulate archives in PHP"
+HOMEPAGE="http://pear.php.net/package/${MY_PN}"
+SRC_URI="http://download.pear.php.net/package/${MY_P}.tgz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="minimal"
+
+RDEPEND="dev-lang/php[bzip2,zlib]
+ dev-php/PEAR-MIME_Type
+ dev-php/PEAR-PEAR
+ !minimal? (
+ dev-php/PEAR-Mail_Mime
+ dev-php/PEAR-Mail
+ dev-php/PEAR-Cache_Lite
+ )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ dodoc README
+
+ insinto /usr/share/php
+ doins -r File
+}