summaryrefslogtreecommitdiff
path: root/dev-php/PEAR-Crypt_HMAC2/PEAR-Crypt_HMAC2-1.0.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-02-15 16:58:00 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-02-15 16:58:00 +0000
commit434d713861b70f6c6563d6ee50a8e64f14c970d9 (patch)
treeb72c523c72e764420f835ba9d63d43ffef687dcf /dev-php/PEAR-Crypt_HMAC2/PEAR-Crypt_HMAC2-1.0.0-r1.ebuild
parentf78108598211053d41752a83e0345441bb9014ae (diff)
gentoo resync : 15.02.2018
Diffstat (limited to 'dev-php/PEAR-Crypt_HMAC2/PEAR-Crypt_HMAC2-1.0.0-r1.ebuild')
-rw-r--r--dev-php/PEAR-Crypt_HMAC2/PEAR-Crypt_HMAC2-1.0.0-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-php/PEAR-Crypt_HMAC2/PEAR-Crypt_HMAC2-1.0.0-r1.ebuild b/dev-php/PEAR-Crypt_HMAC2/PEAR-Crypt_HMAC2-1.0.0-r1.ebuild
new file mode 100644
index 000000000000..2647980b40b1
--- /dev/null
+++ b/dev-php/PEAR-Crypt_HMAC2/PEAR-Crypt_HMAC2-1.0.0-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit php-pear-r2
+
+DESCRIPTION="Implementation of Hashed Message Authentication Code for PHP5"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+DEPEND="test? ( dev-php/PEAR-PEAR dev-php/phpunit )"
+HTML_DOCS=( docs/intro.xml )
+
+src_test() {
+ phpunit tests || die
+}
+
+pkg_postinst() {
+ if ! has_version "dev-lang/php[hash]" ; then
+ elog "${PN} can use the hash extension when enabled to extend the range"
+ elog "of cryptographic hash functions beyond the natively implemented MD5 and SHA1."
+ elog "Recompile dev-lang/php with USE=\"hash\" if you want these features."
+ fi
+}