summaryrefslogtreecommitdiff
path: root/dev-php/PEAR-Console_Table
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-12 00:08:13 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-12 00:08:13 +0100
commitf0ddcad13515f66d2f3bf827d33c277bdba7e1dd (patch)
tree3e1da8fa4626163bda62e9e8b6129867de5be46d /dev-php/PEAR-Console_Table
parent65ff3cc3bd9c3f8e718a67dfecf1f8215bf5d1d4 (diff)
gentoo auto-resync : 12:06:2024 - 00:08:13
Diffstat (limited to 'dev-php/PEAR-Console_Table')
-rw-r--r--dev-php/PEAR-Console_Table/Manifest4
-rw-r--r--dev-php/PEAR-Console_Table/PEAR-Console_Table-1.3.1-r1.ebuild26
-rw-r--r--dev-php/PEAR-Console_Table/PEAR-Console_Table-1.3.1.ebuild4
-rw-r--r--dev-php/PEAR-Console_Table/files/fromArray-is-static.patch22
4 files changed, 53 insertions, 3 deletions
diff --git a/dev-php/PEAR-Console_Table/Manifest b/dev-php/PEAR-Console_Table/Manifest
index 663cff4dfc3e..83a413fc5bbf 100644
--- a/dev-php/PEAR-Console_Table/Manifest
+++ b/dev-php/PEAR-Console_Table/Manifest
@@ -1,3 +1,5 @@
+AUX fromArray-is-static.patch 784 BLAKE2B c225824c27fe0b317ca7e7bf6b80c8d2ff3caca10d621b99d8ee61b05d1ecacb57f63dc6bb32cfa05cbc7783743bf0ae3f05e79c5f0bc929ea0c239d61449396 SHA512 9a2fa201d90787644f9ce2ac1e9c46dcb2d588a6099008f2b8222ddfc4165a4d18a3bb68f750998aa947350e0b959212471b0d0817e46456e110457cc14b4b73
DIST Console_Table-1.3.1.tgz 11492 BLAKE2B bff94b2ae1b6d23eaf9a60deee4e78ee3467eff9d53c1d6ac8330347647b54700d4b3cf30be84c071afc34a4517b3135f6b18011418ea5dfc0e2841da1a30874 SHA512 abac68c20bb670b29f405625edff0330ce5af51763a50ee7482c3ab9d39c7335134d77c0f1a94ce4914c2f454d493a685841e07628eb2aa58cc66617521b6a65
-EBUILD PEAR-Console_Table-1.3.1.ebuild 501 BLAKE2B b5ed46c276fe6e10267a47dc8f25673c7c1a0972cd0bea7f42722abc754d178b1a31c83204eb520f86e147459402f4f80cd2f4ad3ea7de2c2e337344b6f280a9 SHA512 7de92fb39f53784c0f6fec425be4d858118448a596162900458b6a017b1382ef489578a69002a27523354978d4985d1b9375ad98eb4b0bf5b0440af456268fa8
+EBUILD PEAR-Console_Table-1.3.1-r1.ebuild 554 BLAKE2B 91b430037653786af25a2d7c26b48df5318b833db9f355adc54455efe234ede3d1c1001b33470b837238e2724d021c1f54135727a105731ea2e8436ab223d06e SHA512 f32acd6973d1c603a7982e83b561ea98002a1ad8b497c44fab2238d6b3fedfab665c13f869075e45262433a7df4fb1c74afdff40dbf6e6c31594231a1b9eeb05
+EBUILD PEAR-Console_Table-1.3.1.ebuild 497 BLAKE2B b73d99d749138b7a78f16a86d83dfd0b7283adba894b8e88861a5e32decca27ba9ae9c045fac332494a413c2abf6e9ec3cfca5d642f731f7041a38330ca3660f SHA512 b30b9bfc4b81de24a211b1e2d9ab927b43e1fc4e770324e10c0c19d512927460c1ad46499d9860bd0a19bff7765147e455354608b451961afa9bb485fbea839a
MISC metadata.xml 316 BLAKE2B 001c994058c858045dc2a6d274c0e84c97f849539caea66a2bda5041472ded85bf9d8e1fc848a687787c10f9eb23060bf3b3e17bdd56793f0211deada7274fb6 SHA512 bc41a93f7cbb18a2e7ecc25eee9e6a9757aa1c77ef6763e27f00908c522370a49a6fc393eb362314944851902a2025ccd636b902b47f3316f8339f5e28429764
diff --git a/dev-php/PEAR-Console_Table/PEAR-Console_Table-1.3.1-r1.ebuild b/dev-php/PEAR-Console_Table/PEAR-Console_Table-1.3.1-r1.ebuild
new file mode 100644
index 000000000000..2e39a052a20f
--- /dev/null
+++ b/dev-php/PEAR-Console_Table/PEAR-Console_Table-1.3.1-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit php-pear-r2
+
+DESCRIPTION="Class that makes it easy to build console style tables"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc64 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+BDEPEND="test? ( dev-php/pear )"
+
+PATCHES=( "${FILESDIR}/fromArray-is-static.patch" )
+
+src_install() {
+ insinto /usr/share/php/Console
+ doins Table.php
+ php-pear-r2_install_packagexml
+}
+
+src_test() {
+ pear run-tests tests || die "Tests failed"
+}
diff --git a/dev-php/PEAR-Console_Table/PEAR-Console_Table-1.3.1.ebuild b/dev-php/PEAR-Console_Table/PEAR-Console_Table-1.3.1.ebuild
index ab638bb85e46..b29cd9dd7295 100644
--- a/dev-php/PEAR-Console_Table/PEAR-Console_Table-1.3.1.ebuild
+++ b/dev-php/PEAR-Console_Table/PEAR-Console_Table-1.3.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -8,7 +8,7 @@ inherit php-pear-r2
DESCRIPTION="Class that makes it easy to build console style tables"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="amd64 ~hppa ppc ppc64 sparc x86"
+KEYWORDS="amd64 ~hppa ppc64 sparc x86"
IUSE="test"
RESTRICT="!test? ( test )"
BDEPEND="test? ( dev-php/pear )"
diff --git a/dev-php/PEAR-Console_Table/files/fromArray-is-static.patch b/dev-php/PEAR-Console_Table/files/fromArray-is-static.patch
new file mode 100644
index 000000000000..8b068d8f2668
--- /dev/null
+++ b/dev-php/PEAR-Console_Table/files/fromArray-is-static.patch
@@ -0,0 +1,22 @@
+From 4eea320592cc1766b8f679df22c3431a93a74d7e Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Thu, 1 Apr 2021 10:37:33 +0200
+Subject: [PATCH] fromArray is static
+
+---
+ Table.php | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Table.php b/Table.php
+index dbfec73..139433b 100755
+--- a/Table.php
++++ b/Table.php
+@@ -223,7 +223,7 @@ function __construct($align = CONSOLE_TABLE_ALIGN_LEFT,
+ * @return Console_Table|string A Console_Table object or the generated
+ * table.
+ */
+- function fromArray($headers, $data, $returnObject = false)
++ static function fromArray($headers, $data, $returnObject = false)
+ {
+ if (!is_array($headers) || !is_array($data)) {
+ return false;