summaryrefslogtreecommitdiff
path: root/dev-php/PEAR-Config/PEAR-Config-2.0.0_pre20140323.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-php/PEAR-Config/PEAR-Config-2.0.0_pre20140323.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-php/PEAR-Config/PEAR-Config-2.0.0_pre20140323.ebuild')
-rw-r--r--dev-php/PEAR-Config/PEAR-Config-2.0.0_pre20140323.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-php/PEAR-Config/PEAR-Config-2.0.0_pre20140323.ebuild b/dev-php/PEAR-Config/PEAR-Config-2.0.0_pre20140323.ebuild
new file mode 100644
index 000000000000..684a28704a96
--- /dev/null
+++ b/dev-php/PEAR-Config/PEAR-Config-2.0.0_pre20140323.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit php-pear-r2 vcs-snapshot
+
+DESCRIPTION="Provides multiple methods for configuration manipulation"
+LICENSE="PHP-2.02"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="xml"
+RDEPEND="xml? ( dev-php/PEAR-XML_Parser dev-php/PEAR-XML_Util )"
+SRC_URI="https://github.com/pear/Config/archive/606a24034ad80f9d6ccb5a8b698b702b392e4674.tar.gz -> ${PEAR_P}.tar.gz"
+DOCS=( docs/TODO )
+HTML_DOCS=( docs/Apache.php docs/IniCommented.php docs/IniFromScratch.php )
+
+src_prepare() {
+ # Move snapshot location to where the eclass expects
+ mv "${S}/package.xml" "${WORKDIR}/package.xml" || die
+ eapply_user
+}