summaryrefslogtreecommitdiff
path: root/dev-php/PEAR-Cache_Lite/PEAR-Cache_Lite-1.8.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /dev-php/PEAR-Cache_Lite/PEAR-Cache_Lite-1.8.3.ebuild
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'dev-php/PEAR-Cache_Lite/PEAR-Cache_Lite-1.8.3.ebuild')
-rw-r--r--dev-php/PEAR-Cache_Lite/PEAR-Cache_Lite-1.8.3.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-php/PEAR-Cache_Lite/PEAR-Cache_Lite-1.8.3.ebuild b/dev-php/PEAR-Cache_Lite/PEAR-Cache_Lite-1.8.3.ebuild
new file mode 100644
index 000000000000..8e86b80d4732
--- /dev/null
+++ b/dev-php/PEAR-Cache_Lite/PEAR-Cache_Lite-1.8.3.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit php-pear-r2
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+DESCRIPTION="Fast and safe little cache system"
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=dev-php/PEAR-PEAR-1.10.1"
+DEPEND="test? ( ${RDEPEND} )"
+DOCS=( README.md TODO docs/technical docs/examples )
+
+src_test() {
+ peardev run-tests -r || die
+}