summaryrefslogtreecommitdiff
path: root/dev-perl/local-lib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-perl/local-lib
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/local-lib')
-rw-r--r--dev-perl/local-lib/Manifest5
-rw-r--r--dev-perl/local-lib/local-lib-2.0.19.ebuild23
-rw-r--r--dev-perl/local-lib/local-lib-2.0.24.ebuild23
-rw-r--r--dev-perl/local-lib/metadata.xml13
4 files changed, 64 insertions, 0 deletions
diff --git a/dev-perl/local-lib/Manifest b/dev-perl/local-lib/Manifest
new file mode 100644
index 000000000000..f16e78beeff1
--- /dev/null
+++ b/dev-perl/local-lib/Manifest
@@ -0,0 +1,5 @@
+DIST local-lib-2.000019.tar.gz 62149 BLAKE2B 934ec8be32489632870cb7be112cb4328dc4948abac4bf96bc619d13d41e2cdcfd197e261cb6c5d0fff775f3567447b9f57c84ef2a52e2e3cc3dd1616eafdcb3 SHA512 ab7d2d43566fef1d5dce41649859a01306d302b46739cf110b4d0330ae3cec3e49e3b06f67612f9e33b6bcb7654ec5ff0a97cf44fecc8a9cd6d5b24421671614
+DIST local-lib-2.000024.tar.gz 62941 BLAKE2B c618c320af46c9223f67109deb02857755b675223b0a71772227b2c7fec47225e323cdeaa9b2c66e78e9e69964fff0a19367c4e58fa4b9be5e120683e69e9078 SHA512 d23c984f0652ea8dd7028cd2dcc00991e69a5ad1ac6fce9707f953a5e6456d8173b444b7631884e764eb5ff18cea29e8e560c3835eacc0aa34382c0d172a7fd0
+EBUILD local-lib-2.0.19.ebuild 548 BLAKE2B 96674e646e627171ad00d5ee82c6f97dec1f0970d21b56b36505c24eef383234e707a4e137c976d7ba8d9bd7ceb1604d318eeafff66fb630a667e1b145f9da58 SHA512 0dac40314afec1e693dc786ff80da115727eb888fba344b72efa1c266e508bed1d37fd78fd6e7439559699d15131bf1491886c91b66e5f270cb37762355e3547
+EBUILD local-lib-2.0.24.ebuild 550 BLAKE2B 45e20ec309263caebbd99f721b09c98e278e267f2b35d90abbc8c8b756ba8d3ed8cced6dc567806568e2f145cb10d0dd6686ffd0347ccf5273df3df12240e085 SHA512 bbc68251e3c103d23bf499962e700caec6ec4e3e9a32e438166a7ad77525c1b593f89220e2b9c6bb48613ea86c5447979613b39472a760b11ad7c47cc7a79c89
+MISC metadata.xml 480 BLAKE2B b2613e1c31939aa6096fde9b34df7ff601861371ffd532ea6c71d9dff0cb25d7151f2f34c5e7b3fc8b9e0706b383368fb116b4021a8290ea907860eb456572c7 SHA512 0c3b4a34e1c84b9eb03e7b9bae3d11473b60071709ddaae74812d1746d4c97af17f7c08981c8031930dd104dbc08cddaaf96cc081f06ce8c7f06d8126b79f9a6
diff --git a/dev-perl/local-lib/local-lib-2.0.19.ebuild b/dev-perl/local-lib/local-lib-2.0.19.ebuild
new file mode 100644
index 000000000000..653c72072c88
--- /dev/null
+++ b/dev-perl/local-lib/local-lib-2.0.19.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+DIST_AUTHOR=HAARG
+DIST_VERSION=2.000019
+inherit perl-module
+
+DESCRIPTION='create and use a local lib/ for perl modules with PERL5LIB'
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+RDEPEND="
+ >=virtual/perl-CPAN-1.820.0
+ >=virtual/perl-ExtUtils-Install-1.430.0
+ >=virtual/perl-ExtUtils-MakeMaker-7.0.0
+ >=dev-perl/Module-Build-0.360.0
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.590.0
+ test? ( virtual/perl-Test-Simple )
+"
diff --git a/dev-perl/local-lib/local-lib-2.0.24.ebuild b/dev-perl/local-lib/local-lib-2.0.24.ebuild
new file mode 100644
index 000000000000..1f4dabba0f2f
--- /dev/null
+++ b/dev-perl/local-lib/local-lib-2.0.24.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+DIST_AUTHOR=HAARG
+DIST_VERSION=2.000024
+inherit perl-module
+
+DESCRIPTION='create and use a local lib/ for perl modules with PERL5LIB'
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=virtual/perl-CPAN-1.820.0
+ >=virtual/perl-ExtUtils-Install-1.430.0
+ >=virtual/perl-ExtUtils-MakeMaker-7.0.0
+ >=dev-perl/Module-Build-0.360.0
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.590.0
+ test? ( virtual/perl-Test-Simple )
+"
diff --git a/dev-perl/local-lib/metadata.xml b/dev-perl/local-lib/metadata.xml
new file mode 100644
index 000000000000..71ca8805ebd7
--- /dev/null
+++ b/dev-perl/local-lib/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">local-lib</remote-id>
+ <remote-id type="cpan-module">lib::core::only</remote-id>
+ <remote-id type="cpan-module">local::lib</remote-id>
+ </upstream>
+</pkgmetadata>