summaryrefslogtreecommitdiff
path: root/dev-perl/gnome2-perl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-perl/gnome2-perl
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/gnome2-perl')
-rw-r--r--dev-perl/gnome2-perl/Manifest4
-rw-r--r--dev-perl/gnome2-perl/files/Gnome2-1.046-no-dot-inc.patch355
-rw-r--r--dev-perl/gnome2-perl/gnome2-perl-1.46.0.ebuild30
-rw-r--r--dev-perl/gnome2-perl/metadata.xml13
4 files changed, 402 insertions, 0 deletions
diff --git a/dev-perl/gnome2-perl/Manifest b/dev-perl/gnome2-perl/Manifest
new file mode 100644
index 000000000000..8654068e1977
--- /dev/null
+++ b/dev-perl/gnome2-perl/Manifest
@@ -0,0 +1,4 @@
+AUX Gnome2-1.046-no-dot-inc.patch 9535 BLAKE2B 784f1059437726d2e6e93f9b961ea0f712f6a3c2d12938b8b9f01027dec2adfc08c11ccc7466470815fbfdb2be9c3c186b50de441059fbee6d908ccd9bd6d0a0 SHA512 0fdf04f1f71cd365197dc2b641fe7102a1639e70679c902d357eb8c0fc3433d37ef1f519f3029c648587795d17849bad2f9d39e510bcb546c856f03880562991
+DIST Gnome2-1.046.tar.gz 80275 BLAKE2B b6586944ccaa3bb899f7438c32b231846fe89062a94f1031a9d1a9085e81286b7f5694569525c885946c02366bf9afc4a05ce81108a6b9471b35c468c9e3877f SHA512 0e4ee564b4514e63c3b66ef72aad6780e79d0f8d0376d7cbb925c579773d96d5fdf0918c90c0e1cc0f4b0be2c2d0043a54ec700361109c6b4b576627ca1d9efd
+EBUILD gnome2-perl-1.46.0.ebuild 703 BLAKE2B c4147c90782a6bacec466f5f91ba1a934c37fea61f5d213fe467a1f65881b570c87f92b60d6579f38909e4b13d7f1e0c2d7cc0ce3e1e21ffa35cf8f90b7e7bc8 SHA512 0a28d450df461e5213a60905b5a52f2084b17788d55c80142b2166bc196c065330b1488896ebf9c00077354ebc34fb87fb5d59fa01f5f6a91a9ecd55f3444478
+MISC metadata.xml 439 BLAKE2B 37defd2c398c16bf6433214635c75f38c9af376bc4fd01c4ab04641b9604b9e784934bf3da9eb1e261cbb47f663e2d4aa600bf27df286d3a587a93893608c891 SHA512 34ba638f9c96d9cec2036725b71c7604e78ad8fdc6057a5f21bacd86422a3c51420146fc8f756071c34e3b5e654da280096c9c0afb86f808fff5f8b1ce84cea6
diff --git a/dev-perl/gnome2-perl/files/Gnome2-1.046-no-dot-inc.patch b/dev-perl/gnome2-perl/files/Gnome2-1.046-no-dot-inc.patch
new file mode 100644
index 000000000000..1364a89247eb
--- /dev/null
+++ b/dev-perl/gnome2-perl/files/Gnome2-1.046-no-dot-inc.patch
@@ -0,0 +1,355 @@
+From 6d397faa7006e0f3a67595d317e10d3bb81d8792 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Sun, 22 Oct 2017 18:50:01 +1300
+Subject: Fix tests failing on Perl 5.26 without '.' in @INC
+
+eg: With PERL_USE_UNSAFE_INC=0 in ENV
+
+This patch additionally creates safeguards against tests being allowed
+to continue if the "do" call fails for any reason, as do does not
+auto-fatalize, only warns at best.
+
+Bug: https://rt.cpan.org/Ticket/Display.html?id=121440
+Bug: https://bugs.gentoo.org/616954
+---
+ t/Gnome.t | 4 +++-
+ t/GnomeApp.t | 4 +++-
+ t/GnomeAppBar.t | 4 +++-
+ t/GnomeAppHelper.t | 4 +++-
+ t/GnomeColorPicker.t | 4 +++-
+ t/GnomeConfig.t | 4 +++-
+ t/GnomeDateEdit.t | 4 +++-
+ t/GnomeDruid.t | 4 +++-
+ t/GnomeEntry.t | 4 +++-
+ t/GnomeFileEntry.t | 4 +++-
+ t/GnomeFontPicker.t | 4 +++-
+ t/GnomeHRef.t | 4 +++-
+ t/GnomeIconEntry.t | 4 +++-
+ t/GnomeIconList.t | 4 +++-
+ t/GnomeIconSelection.t | 4 +++-
+ t/GnomeIconTheme.t | 4 +++-
+ t/GnomePasswordDialog.t | 4 +++-
+ t/GnomePixmapEntry.t | 4 +++-
+ t/GnomePopupMenu.t | 4 +++-
+ t/GnomeScores.t | 4 +++-
+ t/GnomeThumbnail.t | 4 +++-
+ 21 files changed, 63 insertions(+), 21 deletions(-)
+
+diff --git a/t/Gnome.t b/t/Gnome.t
+index 8b6d0c5..e62b662 100644
+--- a/t/Gnome.t
++++ b/t/Gnome.t
+@@ -11,7 +11,9 @@ use Test::More tests => TESTS;
+
+ SKIP: {
+ our $application;
+- do "t/TestBoilerplate";
++ do "./t/TestBoilerplate";
++ die $@ if $@;
++ die $! if $!;
+
+ #############################################################################
+
+diff --git a/t/GnomeApp.t b/t/GnomeApp.t
+index d7fc143..49420c3 100644
+--- a/t/GnomeApp.t
++++ b/t/GnomeApp.t
+@@ -11,7 +11,9 @@ use Test::More tests => TESTS;
+
+ SKIP: {
+ our $application;
+- do "t/TestBoilerplate";
++ do "./t/TestBoilerplate";
++ die $@ if $@;
++ die $! if $!;
+
+ #############################################################################
+
+diff --git a/t/GnomeAppBar.t b/t/GnomeAppBar.t
+index 22ac53d..b127b2c 100644
+--- a/t/GnomeAppBar.t
++++ b/t/GnomeAppBar.t
+@@ -11,7 +11,9 @@ use Test::More tests => TESTS;
+
+ SKIP: {
+ our $application;
+- do "t/TestBoilerplate";
++ do "./t/TestBoilerplate";
++ die $@ if $@;
++ die $! if $!;
+
+ #############################################################################
+
+diff --git a/t/GnomeAppHelper.t b/t/GnomeAppHelper.t
+index 849bfe7..5ed6350 100644
+--- a/t/GnomeAppHelper.t
++++ b/t/GnomeAppHelper.t
+@@ -11,7 +11,9 @@ use Test::More tests => TESTS;
+
+ SKIP: {
+ our $application;
+- do "t/TestBoilerplate";
++ do "./t/TestBoilerplate";
++ die $@ if $@;
++ die $! if $!;
+
+ #############################################################################
+
+diff --git a/t/GnomeColorPicker.t b/t/GnomeColorPicker.t
+index 7f7fba9..8dcee3e 100644
+--- a/t/GnomeColorPicker.t
++++ b/t/GnomeColorPicker.t
+@@ -11,7 +11,9 @@ use Test::More tests => TESTS;
+
+ SKIP: {
+ our $application;
+- do "t/TestBoilerplate";
++ do "./t/TestBoilerplate";
++ die $@ if $@;
++ die $! if $!;
+
+ #############################################################################
+
+diff --git a/t/GnomeConfig.t b/t/GnomeConfig.t
+index 2c42a14..24973be 100644
+--- a/t/GnomeConfig.t
++++ b/t/GnomeConfig.t
+@@ -11,7 +11,9 @@ use Test::More tests => TESTS;
+
+ SKIP: {
+ our $application;
+- do "t/TestBoilerplate";
++ do "./t/TestBoilerplate";
++ die $@ if $@;
++ die $! if $!;
+
+ #############################################################################
+
+diff --git a/t/GnomeDateEdit.t b/t/GnomeDateEdit.t
+index a8f2e33..addd98d 100644
+--- a/t/GnomeDateEdit.t
++++ b/t/GnomeDateEdit.t
+@@ -11,7 +11,9 @@ use Test::More tests => TESTS;
+
+ SKIP: {
+ our $application;
+- do "t/TestBoilerplate";
++ do "./t/TestBoilerplate";
++ die $@ if $@;
++ die $! if $!;
+
+ #############################################################################
+
+diff --git a/t/GnomeDruid.t b/t/GnomeDruid.t
+index c209004..21a9fdd 100644
+--- a/t/GnomeDruid.t
++++ b/t/GnomeDruid.t
+@@ -11,7 +11,9 @@ use Test::More tests => TESTS;
+
+ SKIP: {
+ our $application;
+- do "t/TestBoilerplate";
++ do "./t/TestBoilerplate";
++ die $@ if $@;
++ die $! if $!;
+
+ #############################################################################
+
+diff --git a/t/GnomeEntry.t b/t/GnomeEntry.t
+index c2d2b68..a0aa95a 100644
+--- a/t/GnomeEntry.t
++++ b/t/GnomeEntry.t
+@@ -11,7 +11,9 @@ use Test::More tests => TESTS;
+
+ SKIP: {
+ our $application;
+- do "t/TestBoilerplate";
++ do "./t/TestBoilerplate";
++ die $@ if $@;
++ die $! if $!;
+
+ #############################################################################
+
+diff --git a/t/GnomeFileEntry.t b/t/GnomeFileEntry.t
+index 91befa8..1d572a9 100644
+--- a/t/GnomeFileEntry.t
++++ b/t/GnomeFileEntry.t
+@@ -11,7 +11,9 @@ use Test::More tests => TESTS;
+
+ SKIP: {
+ our $application;
+- do "t/TestBoilerplate";
++ do "./t/TestBoilerplate";
++ die $@ if $@;
++ die $! if $!;
+
+ #############################################################################
+
+diff --git a/t/GnomeFontPicker.t b/t/GnomeFontPicker.t
+index a2e8e68..98520db 100644
+--- a/t/GnomeFontPicker.t
++++ b/t/GnomeFontPicker.t
+@@ -11,7 +11,9 @@ use Test::More tests => TESTS;
+
+ SKIP: {
+ our $application;
+- do "t/TestBoilerplate";
++ do "./t/TestBoilerplate";
++ die $@ if $@;
++ die $! if $!;
+
+ #############################################################################
+
+diff --git a/t/GnomeHRef.t b/t/GnomeHRef.t
+index 256347b..484fa61 100644
+--- a/t/GnomeHRef.t
++++ b/t/GnomeHRef.t
+@@ -11,7 +11,9 @@ use Test::More tests => TESTS;
+
+ SKIP: {
+ our $application;
+- do "t/TestBoilerplate";
++ do "./t/TestBoilerplate";
++ die $@ if $@;
++ die $! if $!;
+
+ #############################################################################
+
+diff --git a/t/GnomeIconEntry.t b/t/GnomeIconEntry.t
+index 35ef1e6..957efc0 100644
+--- a/t/GnomeIconEntry.t
++++ b/t/GnomeIconEntry.t
+@@ -11,7 +11,9 @@ use Test::More tests => TESTS;
+
+ SKIP: {
+ our $application;
+- do "t/TestBoilerplate";
++ do "./t/TestBoilerplate";
++ die $@ if $@;
++ die $! if $!;
+
+ #############################################################################
+
+diff --git a/t/GnomeIconList.t b/t/GnomeIconList.t
+index 2bf9eb1..8067a70 100644
+--- a/t/GnomeIconList.t
++++ b/t/GnomeIconList.t
+@@ -11,7 +11,9 @@ use Test::More skip_all => "Seems to be broken", tests => TESTS;
+
+ SKIP: {
+ our $application;
+- do "t/TestBoilerplate";
++ do "./t/TestBoilerplate";
++ die $@ if $@;
++ die $! if $!;
+
+ #############################################################################
+
+diff --git a/t/GnomeIconSelection.t b/t/GnomeIconSelection.t
+index 35117c9..566ae85 100644
+--- a/t/GnomeIconSelection.t
++++ b/t/GnomeIconSelection.t
+@@ -11,7 +11,9 @@ use Test::More tests => TESTS;
+
+ SKIP: {
+ our $application;
+- do "t/TestBoilerplate";
++ do "./t/TestBoilerplate";
++ die $@ if $@;
++ die $! if $!;
+
+ #############################################################################
+
+diff --git a/t/GnomeIconTheme.t b/t/GnomeIconTheme.t
+index 9baeb4c..dda3582 100644
+--- a/t/GnomeIconTheme.t
++++ b/t/GnomeIconTheme.t
+@@ -13,7 +13,9 @@ Gnome2::VFS -> init();
+
+ SKIP: {
+ our $application;
+- do "t/TestBoilerplate";
++ do "./t/TestBoilerplate";
++ die $@ if $@;
++ die $! if $!;
+
+ skip("GnomeIconTheme is new in 2.0.6", TESTS)
+ unless (Gnome2 -> CHECK_VERSION(2, 0, 6));
+diff --git a/t/GnomePasswordDialog.t b/t/GnomePasswordDialog.t
+index 51c548c..38b2dcb 100644
+--- a/t/GnomePasswordDialog.t
++++ b/t/GnomePasswordDialog.t
+@@ -10,7 +10,9 @@ use Test::More tests => TESTS;
+ ###############################################################################
+
+ SKIP: {
+- do "t/TestBoilerplate";
++ do "./t/TestBoilerplate";
++ die $@ if $@;
++ die $! if $!;
+
+ skip("GnomePasswordDialog and GnomeAuthenticationManager didn't appear until 2.4.0", TESTS)
+ unless (Gnome2 -> CHECK_VERSION(2, 4, 0));
+diff --git a/t/GnomePixmapEntry.t b/t/GnomePixmapEntry.t
+index 17e4996..dbfe42c 100644
+--- a/t/GnomePixmapEntry.t
++++ b/t/GnomePixmapEntry.t
+@@ -11,7 +11,9 @@ use Test::More tests => TESTS;
+
+ SKIP: {
+ our $application;
+- do "t/TestBoilerplate";
++ do "./t/TestBoilerplate";
++ die $@ if $@;
++ die $! if $!;
+
+ #############################################################################
+
+diff --git a/t/GnomePopupMenu.t b/t/GnomePopupMenu.t
+index 20275c9..151f410 100644
+--- a/t/GnomePopupMenu.t
++++ b/t/GnomePopupMenu.t
+@@ -11,7 +11,9 @@ use Test::More tests => TESTS;
+
+ SKIP: {
+ our $application;
+- do "t/TestBoilerplate";
++ do "./t/TestBoilerplate";
++ die $@ if $@;
++ die $! if $!;
+
+ #############################################################################
+
+diff --git a/t/GnomeScores.t b/t/GnomeScores.t
+index 1b21ab2..82aa3a3 100644
+--- a/t/GnomeScores.t
++++ b/t/GnomeScores.t
+@@ -11,7 +11,9 @@ use Test::More tests => TESTS;
+
+ SKIP: {
+ our $application;
+- do "t/TestBoilerplate";
++ do "./t/TestBoilerplate";
++ die $@ if $@;
++ die $! if $!;
+
+ #############################################################################
+
+diff --git a/t/GnomeThumbnail.t b/t/GnomeThumbnail.t
+index ec0095f..ba24928 100644
+--- a/t/GnomeThumbnail.t
++++ b/t/GnomeThumbnail.t
+@@ -11,7 +11,9 @@ use Test::More tests => TESTS;
+
+ SKIP: {
+ our $application;
+- do "t/TestBoilerplate";
++ do "./t/TestBoilerplate";
++ die $@ if $@;
++ die $! if $!;
+
+ skip("GnomeThumbnail is new in 2.0.6", 4)
+ unless (Gnome2 -> CHECK_VERSION(2, 0, 6));
+--
+2.14.2
+
diff --git a/dev-perl/gnome2-perl/gnome2-perl-1.46.0.ebuild b/dev-perl/gnome2-perl/gnome2-perl-1.46.0.ebuild
new file mode 100644
index 000000000000..3c502defb56e
--- /dev/null
+++ b/dev-perl/gnome2-perl/gnome2-perl-1.46.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_NAME=Gnome2
+DIST_AUTHOR=XAOC
+DIST_VERSION=1.046
+inherit perl-module
+
+DESCRIPTION="Perl interface to the 2.x series of the Gnome libraries"
+HOMEPAGE="http://gtk2-perl.sourceforge.net/ ${HOMEPAGE}"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 ~ppc x86"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2
+ dev-perl/Gtk2
+ gnome-base/libgnomeui
+ gnome-base/libbonoboui
+ dev-perl/gnome2-canvas
+ >=dev-perl/glib-perl-1.40.0
+ dev-perl/gnome2-vfs-perl"
+DEPEND="${RDEPEND}
+ dev-perl/ExtUtils-Depends
+ dev-perl/ExtUtils-PkgConfig"
+
+PATCHES=( "${FILESDIR}/${DIST_NAME}-${DIST_VERSION}-no-dot-inc.patch" )
diff --git a/dev-perl/gnome2-perl/metadata.xml b/dev-perl/gnome2-perl/metadata.xml
new file mode 100644
index 000000000000..cf4fe7a16770
--- /dev/null
+++ b/dev-perl/gnome2-perl/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">Gnome2</remote-id>
+ <remote-id type="cpan-module">Gnome2</remote-id>
+ <remote-id type="sourceforge">gtk2-perl</remote-id>
+ </upstream>
+</pkgmetadata>