summaryrefslogtreecommitdiff
path: root/dev-perl/XML-Validator-Schema/XML-Validator-Schema-1.100.0-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-perl/XML-Validator-Schema/XML-Validator-Schema-1.100.0-r2.ebuild
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-perl/XML-Validator-Schema/XML-Validator-Schema-1.100.0-r2.ebuild')
-rw-r--r--dev-perl/XML-Validator-Schema/XML-Validator-Schema-1.100.0-r2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-perl/XML-Validator-Schema/XML-Validator-Schema-1.100.0-r2.ebuild b/dev-perl/XML-Validator-Schema/XML-Validator-Schema-1.100.0-r2.ebuild
new file mode 100644
index 000000000000..12692f444b2e
--- /dev/null
+++ b/dev-perl/XML-Validator-Schema/XML-Validator-Schema-1.100.0-r2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=SAMTREGAR
+DIST_VERSION=1.10
+
+inherit perl-module
+
+DESCRIPTION="Validate XML against a subset of W3C XML Schema"
+
+SLOT="0"
+KEYWORDS="~amd64"
+
+# >= on XML-Sax needed to avoid "miscompilation" (essentially empty install), as newer XML-Sax
+# has the ROOT check fixed. Didn't happen with XML-SAX-Expat, but best to be careful.
+# bug #840053
+RDEPEND="
+ >=dev-perl/XML-SAX-1.20.0-r1
+ dev-perl/Tree-DAG_Node
+ dev-perl/XML-Filter-BufferText
+"
+BDEPEND="${RDEPEND}
+"