summaryrefslogtreecommitdiff
path: root/dev-perl/XML-SAX/XML-SAX-1.20.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-perl/XML-SAX/XML-SAX-1.20.0-r1.ebuild
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-perl/XML-SAX/XML-SAX-1.20.0-r1.ebuild')
-rw-r--r--dev-perl/XML-SAX/XML-SAX-1.20.0-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-perl/XML-SAX/XML-SAX-1.20.0-r1.ebuild b/dev-perl/XML-SAX/XML-SAX-1.20.0-r1.ebuild
new file mode 100644
index 000000000000..b03a479f01a2
--- /dev/null
+++ b/dev-perl/XML-SAX/XML-SAX-1.20.0-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=GRANTM
+DIST_VERSION=1.02
+inherit perl-module
+
+DESCRIPTION="Perl module for using and building Perl SAX2 XML parsers, filters, and drivers"
+
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="
+ >=dev-perl/XML-SAX-Base-1.50.0
+ >=dev-perl/XML-NamespaceSupport-0.30.0
+ >=dev-libs/libxml2-2.4.1
+ virtual/perl-File-Temp
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"
+
+PATCHES=("${FILESDIR}/${PN}-1.00-noautoini.patch")
+
+pkg_postinst() {
+ pkg_update_parser add XML::SAX::PurePerl
+}
+
+pkg_update_parser() {
+ # pkg_update_parser [add|remove] $parser_module
+ local action=$1
+ local parser_module=$2
+
+ if [[ -z "${ROOT}" ]] ; then
+ einfo "Update Parser: $1 $2"
+ perl -MXML::SAX -e "XML::SAX->${action}_parser(q(${parser_module}))->save_parsers()" \
+ || ewarn "Update Parser: $1 $2 failed"
+ else
+ elog "To $1 $2 run:"
+ elog "perl -MXML::SAX -e 'XML::SAX->${action}_parser(q(${parser_module}))->save_parsers()'"
+ fi
+}