summaryrefslogtreecommitdiff
path: root/dev-perl/XML-SAX/XML-SAX-0.990.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-perl/XML-SAX/XML-SAX-0.990.0-r1.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/XML-SAX/XML-SAX-0.990.0-r1.ebuild')
-rw-r--r--dev-perl/XML-SAX/XML-SAX-0.990.0-r1.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/dev-perl/XML-SAX/XML-SAX-0.990.0-r1.ebuild b/dev-perl/XML-SAX/XML-SAX-0.990.0-r1.ebuild
deleted file mode 100644
index ddc6ea980067..000000000000
--- a/dev-perl/XML-SAX/XML-SAX-0.990.0-r1.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-MODULE_AUTHOR=GRANTM
-MODULE_VERSION=0.99
-inherit perl-module eutils
-
-DESCRIPTION="Perl module for using and building Perl SAX2 XML parsers, filters, and drivers"
-
-SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-RDEPEND="
- dev-perl/XML-SAX-Base
- >=dev-perl/XML-NamespaceSupport-1.40.0
- >=dev-libs/libxml2-2.4.1
-"
-DEPEND="${RDEPEND}"
-
-SRC_TEST="do"
-
-src_prepare() {
- sed -i \
- -e 's/if (\$write_ini_ok)/if (0 \&\& $write_ini_ok)/' \
- Makefile.PL || die
- epatch "${FILESDIR}"/encodings.patch
-}
-
-pkg_postinst() {
- pkg_update_parser add XML::SAX::PurePerl
-}
-
-pkg_update_parser() {
- # pkg_update_parser [add|remove] $parser_module
- local action=$1
- local parser_module=$2
-
- if [[ "$ROOT" = "/" ]] ; then
- einfo "Update Parser: $1 $2"
- perl -MXML::SAX -e "XML::SAX->${action}_parser(q(${parser_module}))->save_parsers()" \
- || ewarn "Update Parser: $1 $2 failed"
- else
- elog "To $1 $2 run:"
- elog "perl -MXML::SAX -e 'XML::SAX->${action}_parser(q(${parser_module}))->save_parsers()'"
- fi
-}