summaryrefslogtreecommitdiff
path: root/dev-perl/XML-LibXSLT/XML-LibXSLT-2.2.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-12 09:56:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-12 09:56:54 +0000
commitebc282ef4dfa408accac685565b8ee5f6faec119 (patch)
treec0a4f713228cda0ab17eed46f0bb7ca8cb8be2f6 /dev-perl/XML-LibXSLT/XML-LibXSLT-2.2.1.ebuild
parent6c8694a707151d59555b0e4e48235f085ce166c3 (diff)
gentoo auto-resync : 12:02:2023 - 09:56:54
Diffstat (limited to 'dev-perl/XML-LibXSLT/XML-LibXSLT-2.2.1.ebuild')
-rw-r--r--dev-perl/XML-LibXSLT/XML-LibXSLT-2.2.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-perl/XML-LibXSLT/XML-LibXSLT-2.2.1.ebuild b/dev-perl/XML-LibXSLT/XML-LibXSLT-2.2.1.ebuild
new file mode 100644
index 000000000000..8560951604f8
--- /dev/null
+++ b/dev-perl/XML-LibXSLT/XML-LibXSLT-2.2.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=SHLOMIF
+DIST_VERSION=2.002001
+inherit perl-module
+
+DESCRIPTION="A Perl module to parse XSL Transformational sheets using GNOME's libxslt"
+
+# https://github.com/shlomif/perl-XML-LibXSLT/issues/5
+LICENSE="|| ( Artistic GPL-1+ ) MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ virtual/perl-Encode
+ >=dev-perl/XML-LibXML-1.700.0
+ >=dev-libs/libxslt-1.1.32
+"
+BDEPEND="
+ ${RDEPEND}
+ >=virtual/perl-File-Path-2.60.0
+ virtual/pkgconfig
+"
+
+PERL_RM_FILES=(
+ "t/cpan-changes.t" "t/pod.t"
+ "t/style-trailing-space.t"
+)