summaryrefslogtreecommitdiff
path: root/dev-perl/Wx-Scintilla/Wx-Scintilla-0.390.0-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-perl/Wx-Scintilla/Wx-Scintilla-0.390.0-r2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-perl/Wx-Scintilla/Wx-Scintilla-0.390.0-r2.ebuild')
-rw-r--r--dev-perl/Wx-Scintilla/Wx-Scintilla-0.390.0-r2.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-perl/Wx-Scintilla/Wx-Scintilla-0.390.0-r2.ebuild b/dev-perl/Wx-Scintilla/Wx-Scintilla-0.390.0-r2.ebuild
new file mode 100644
index 000000000000..b11bb08f1896
--- /dev/null
+++ b/dev-perl/Wx-Scintilla/Wx-Scintilla-0.390.0-r2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+WX_GTK_VER="3.0"
+#VIRTUALX_REQUIRED=test
+#inherit virtualx
+MODULE_AUTHOR=AZAWAWI
+MODULE_VERSION=0.39
+inherit wxwidgets perl-module
+
+DESCRIPTION="Scintilla source code editing component for wxWidgets"
+
+LICENSE+=" HPND"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-perl/Alien-wxWidgets
+ dev-perl/Wx
+ x11-libs/wxGTK:${WX_GTK_VER}
+"
+DEPEND="${RDEPEND}
+ >=dev-perl/ExtUtils-XSpp-0.160.200
+ >=dev-perl/Module-Build-0.360.0
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.34-flags.patch
+ "${FILESDIR}"/${PN}-0.39-gcc6.patch
+)
+
+src_configure() {
+ need-wxwidgets base-unicode
+ myconf=( --verbose )
+ perl-module_src_configure
+}
+
+#SRC_TEST=do
+#src_test() {
+# VIRTUALX_COMMAND="./Build" virtualmake test || die
+#}