summaryrefslogtreecommitdiff
path: root/dev-perl/WWW-Bugzilla
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-23 04:19:44 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-03-23 04:19:44 +0000
commitc5283d322accc6097afec74eab24550829788bab (patch)
treeb99ce668128d82a026eaa31461643f9173f9b77b /dev-perl/WWW-Bugzilla
parent5510d9d7d1c93c2ea71a2bd6f0666168808d5dd6 (diff)
gentoo resync : 23.03.2018
Diffstat (limited to 'dev-perl/WWW-Bugzilla')
-rw-r--r--dev-perl/WWW-Bugzilla/Manifest1
-rw-r--r--dev-perl/WWW-Bugzilla/WWW-Bugzilla-1.500.0-r2.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-perl/WWW-Bugzilla/Manifest b/dev-perl/WWW-Bugzilla/Manifest
index 9ad9858f7f73..d0570863b9f3 100644
--- a/dev-perl/WWW-Bugzilla/Manifest
+++ b/dev-perl/WWW-Bugzilla/Manifest
@@ -1,3 +1,4 @@
DIST WWW-Bugzilla-1.5.tar.gz 22498 BLAKE2B 78f6b53673e246ab62b43b014677d6a2ab31b6b67061198e0faedb183f542f53d2e709993684baae0206587bebd005aa5e5662e9ffa82732f91447fde397aaf6 SHA512 f738d1c38a0dd5841fd883ed56a0f376212cbbcdfa4df476d655ac17086a369ab9f956ec982af9cd6eb740723597eddc74d1dc452c23ec89b0e15ef75c51efca
EBUILD WWW-Bugzilla-1.500.0-r1.ebuild 514 BLAKE2B 307c949cbfc44d80324749282d9c03ac438473f49a938cc71e5054730cb97c685ea89fc8da1ce8f50bdea643c96513abc576124cfc1821f42a8cd57e4ad30286 SHA512 693b306920996de1be3e2d0eda61dabcec164d51f2bc1018a8b4288c19992ae41fbb7540b404fd7810576040b274ea5e9c3abd63ebd1c658985675781c704ef9
+EBUILD WWW-Bugzilla-1.500.0-r2.ebuild 1095 BLAKE2B 1e8887ea2432e62c4fee07b076a8954173967723d96a55cf8d282a65da78faf7a277bdc41dffcf58fd63ebc9adc3b723bb081a3695550f323dc996a7589eb085 SHA512 766dedf60f1ac3b57f232786c54919a34ac744bcc05579c281b2e47d63042a9c09b79bbdc499fd468773dfffe78a330d26123a5811016d3294083289a85111a7
MISC metadata.xml 464 BLAKE2B 68c96c15241cf925f249703580d4d0d3ed4799ae432cd9b34b576d359988d2d4092725daeac6c8e0a7a01261c3303cb13b287e8ef38701351c46eaa08b55a503 SHA512 1c82b84ca6ba240aa23f6416cd20f90acaaac8f09c808f653bf1abb533b908b25ca53bab164ce36ca335ba06d05bb7727bb1895f42904ba965e7732d3f713841
diff --git a/dev-perl/WWW-Bugzilla/WWW-Bugzilla-1.500.0-r2.ebuild b/dev-perl/WWW-Bugzilla/WWW-Bugzilla-1.500.0-r2.ebuild
new file mode 100644
index 000000000000..b860738c147c
--- /dev/null
+++ b/dev-perl/WWW-Bugzilla/WWW-Bugzilla-1.500.0-r2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=BMC
+DIST_VERSION=1.5
+inherit perl-module
+
+DESCRIPTION="Automate interaction with bugzilla"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-perl/WWW-Mechanize-1.300.0
+ >=dev-perl/Params-Validate-0.880.0
+ >=dev-perl/Crypt-SSLeay-0.570.0
+ >=dev-perl/Class-MethodMaker-1.80.0"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ perl-module_src_prepare
+ mkdir "${S}"/lib || die "Can't mkdir lib"
+ cp -r "${S}"/{WWW,lib} || die "Can't copy WWW"
+}
+
+# Network tests are broken
+DIST_TEST="skip"
+src_test() {
+ local MODULES=(
+ "WWW::Bugzilla ${DIST_VERSION}"
+ "WWW::Bugzilla::Search 0.1"
+ )
+ local failed=()
+ for dep in "${MODULES[@]}"; do
+ ebegin "Compile testing ${dep}"
+ perl -Mblib="${S}" -M"${dep} ()" -e1
+ eend $? || failed+=( "$dep" )
+ done
+ if [[ ${failed[@]} ]]; then
+ echo
+ eerror "One or more modules failed compile:";
+ for dep in "${failed[@]}"; do
+ eerror " ${dep}"
+ done
+ die "Failing due to module compilation errors";
+ fi
+ perl-module_src_test
+}