summaryrefslogtreecommitdiff
path: root/dev-perl/Video-Frequencies/Video-Frequencies-0.30.0-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-08 23:06:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-08 23:06:07 +0100
commite23a08d0c97a0cc415aaa165da840b056f93c997 (patch)
tree4c5f7db60483518201fef36f8cc0712789a08db2 /dev-perl/Video-Frequencies/Video-Frequencies-0.30.0-r3.ebuild
parent391b5b359a346aff490103da7dddc85047f83830 (diff)
gentoo resync : 08.10.2021
Diffstat (limited to 'dev-perl/Video-Frequencies/Video-Frequencies-0.30.0-r3.ebuild')
-rw-r--r--dev-perl/Video-Frequencies/Video-Frequencies-0.30.0-r3.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-perl/Video-Frequencies/Video-Frequencies-0.30.0-r3.ebuild b/dev-perl/Video-Frequencies/Video-Frequencies-0.30.0-r3.ebuild
new file mode 100644
index 000000000000..71ed33d5699a
--- /dev/null
+++ b/dev-perl/Video-Frequencies/Video-Frequencies-0.30.0-r3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_VERSION=0.03
+inherit perl-module
+
+DESCRIPTION="Video Frequencies perl module, for use with ivtv-ptune"
+HOMEPAGE="http://ivtv.sourceforge.net"
+SRC_URI="mirror://sourceforge/ivtv/${PN}-${DIST_VERSION}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ia64 ppc x86"
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ export OPTIMIZE="$CFLAGS"
+ perl-module_src_configure
+}
+
+src_test() {
+ ebegin "Compile testing Video::Frequencies ${PV}"
+ perl -Mblib="${S}" -M"Video::Frequencies ${PV} ()" -e1
+ if ! eend $?; then
+ echo
+ eerror "One or more modules failed compile:";
+ eerror " Video::Frequencies ${PV}"
+ die "Failing due to module compilation errors";
+ fi
+ perl-module_src_test
+}