summaryrefslogtreecommitdiff
path: root/dev-perl/Variable-Magic/Variable-Magic-0.630.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-18 01:46:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-18 01:46:36 +0100
commit81ab1a4db30480fdfb51d6e784b0f3ad9bbe2432 (patch)
tree5c2bb8712bddd53ef4c66cd7179cc7840e8c778f /dev-perl/Variable-Magic/Variable-Magic-0.630.0.ebuild
parent59fb6ea4eff116f078307a57217645762b78aba7 (diff)
gentoo auto-resync : 18:06:2023 - 01:46:36
Diffstat (limited to 'dev-perl/Variable-Magic/Variable-Magic-0.630.0.ebuild')
-rw-r--r--dev-perl/Variable-Magic/Variable-Magic-0.630.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-perl/Variable-Magic/Variable-Magic-0.630.0.ebuild b/dev-perl/Variable-Magic/Variable-Magic-0.630.0.ebuild
new file mode 100644
index 000000000000..b8f34856101c
--- /dev/null
+++ b/dev-perl/Variable-Magic/Variable-Magic-0.630.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=VPIT
+DIST_VERSION=0.63
+DIST_EXAMPLES=("samples/*")
+inherit perl-module
+
+DESCRIPTION="Associate user-defined magic to variables from Perl"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+RDEPEND="
+ virtual/perl-Carp
+ virtual/perl-Exporter
+ virtual/perl-XSLoader
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-Test-Simple
+ )
+"