summaryrefslogtreecommitdiff
path: root/dev-perl/Type-Tiny/Type-Tiny-2.2.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-13 08:16:09 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-13 08:16:09 +0000
commit4a74938e510c0dad732ae4c48f815dd0f0cabb46 (patch)
treee8c52cd3619bba6cf0a5c367f6c9d2cff0ac9d80 /dev-perl/Type-Tiny/Type-Tiny-2.2.1-r1.ebuild
parentebc282ef4dfa408accac685565b8ee5f6faec119 (diff)
gentoo auto-resync : 13:02:2023 - 08:16:09
Diffstat (limited to 'dev-perl/Type-Tiny/Type-Tiny-2.2.1-r1.ebuild')
-rw-r--r--dev-perl/Type-Tiny/Type-Tiny-2.2.1-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-perl/Type-Tiny/Type-Tiny-2.2.1-r1.ebuild b/dev-perl/Type-Tiny/Type-Tiny-2.2.1-r1.ebuild
new file mode 100644
index 000000000000..cf9ae88fdc52
--- /dev/null
+++ b/dev-perl/Type-Tiny/Type-Tiny-2.2.1-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=TOBYINK
+DIST_VERSION=2.002001
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="tiny, yet Moo(se)-compatible type constraint"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~m68k ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+IUSE="test minimal"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ !<dev-perl/Kavorka-0.13.0
+ !<dev-perl/Types-ReadOnly-0.1.0
+ !dev-perl/Type-Tie
+ >=dev-perl/Exporter-Tiny-1.4.1
+ >=virtual/perl-Test-Simple-1.1.10
+ !minimal? (
+ >=dev-perl/Class-XSAccessor-1.170.0
+ >=dev-perl/Devel-LexAlias-0.50.0
+ dev-perl/Devel-StackTrace
+ >=dev-perl/Ref-Util-XS-0.100.0
+ >=dev-perl/Regexp-Util-0.3.0
+ virtual/perl-Scalar-List-Utils
+ >=dev-perl/Type-Tiny-XS-0.25.0
+ )
+"
+BDEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.170.0
+ >=virtual/perl-CPAN-Meta-Requirements-2.0.0
+ test? (
+ dev-perl/Test-Warnings
+ )
+"