summaryrefslogtreecommitdiff
path: root/dev-perl/Type-Tiny/Type-Tiny-1.12.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /dev-perl/Type-Tiny/Type-Tiny-1.12.3.ebuild
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'dev-perl/Type-Tiny/Type-Tiny-1.12.3.ebuild')
-rw-r--r--dev-perl/Type-Tiny/Type-Tiny-1.12.3.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-perl/Type-Tiny/Type-Tiny-1.12.3.ebuild b/dev-perl/Type-Tiny/Type-Tiny-1.12.3.ebuild
new file mode 100644
index 000000000000..34dbab8a2888
--- /dev/null
+++ b/dev-perl/Type-Tiny/Type-Tiny-1.12.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=TOBYINK
+DIST_VERSION=1.012003
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="tiny, yet Moo(se)-compatible type constraint"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+IUSE="test minimal"
+RESTRICT="!test? ( test )"
+
+# Test rdep for Test::TypeTiny
+RDEPEND="
+ !<dev-perl/Kavorka-0.13.0
+ !<dev-perl/Types-ReadOnly-0.1.0
+ >=dev-perl/Exporter-Tiny-1.0.0
+ >=virtual/perl-Test-Simple-1.1.10
+ !minimal? (
+ >=dev-perl/Devel-LexAlias-0.50.0
+ dev-perl/Devel-StackTrace
+ >=dev-perl/Ref-Util-XS-0.100.0
+ >=dev-perl/Regexp-Util-0.3.0
+ virtual/perl-Scalar-List-Utils
+ dev-perl/Type-Tie
+ >=dev-perl/Type-Tiny-XS-0.16.0
+ )
+"
+BDEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.170.0
+ >=virtual/perl-CPAN-Meta-Requirements-2.0.0
+ test? (
+ dev-perl/Test-Warnings
+ )
+"