summaryrefslogtreecommitdiff
path: root/dev-perl/Type-Tiny-XS/Type-Tiny-XS-0.25.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-12 09:56:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-12 09:56:54 +0000
commitebc282ef4dfa408accac685565b8ee5f6faec119 (patch)
treec0a4f713228cda0ab17eed46f0bb7ca8cb8be2f6 /dev-perl/Type-Tiny-XS/Type-Tiny-XS-0.25.0.ebuild
parent6c8694a707151d59555b0e4e48235f085ce166c3 (diff)
gentoo auto-resync : 12:02:2023 - 09:56:54
Diffstat (limited to 'dev-perl/Type-Tiny-XS/Type-Tiny-XS-0.25.0.ebuild')
-rw-r--r--dev-perl/Type-Tiny-XS/Type-Tiny-XS-0.25.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-perl/Type-Tiny-XS/Type-Tiny-XS-0.25.0.ebuild b/dev-perl/Type-Tiny-XS/Type-Tiny-XS-0.25.0.ebuild
new file mode 100644
index 000000000000..31d28de2b9d6
--- /dev/null
+++ b/dev-perl/Type-Tiny-XS/Type-Tiny-XS-0.25.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=TOBYINK
+DIST_VERSION=0.025
+inherit perl-module
+
+DESCRIPTION="provides an XS boost for some of Type::Tiny's built-in type constraints"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+IUSE="test minimal"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ !minimal? ( dev-perl/Type-Tiny )
+"
+BDEPEND="
+ ${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.580.0
+ >=virtual/perl-ExtUtils-ParseXS-3.160.0
+ test? (
+ >=virtual/perl-Test-Simple-0.920.0
+ )
+"