summaryrefslogtreecommitdiff
path: root/dev-perl/Tie-Cycle/Tie-Cycle-1.224.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-perl/Tie-Cycle/Tie-Cycle-1.224.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-perl/Tie-Cycle/Tie-Cycle-1.224.0.ebuild')
-rw-r--r--dev-perl/Tie-Cycle/Tie-Cycle-1.224.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-perl/Tie-Cycle/Tie-Cycle-1.224.0.ebuild b/dev-perl/Tie-Cycle/Tie-Cycle-1.224.0.ebuild
new file mode 100644
index 000000000000..cd7d88853ac1
--- /dev/null
+++ b/dev-perl/Tie-Cycle/Tie-Cycle-1.224.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=BDFOY
+DIST_VERSION=1.224
+inherit perl-module
+
+DESCRIPTION="Cycle through a list of values via a scalar"
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="virtual/perl-Carp"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.640.0
+ virtual/perl-File-Spec
+ test? (
+ >=virtual/perl-Test-Simple-0.950.0
+ )
+"
+src_test() {
+ perl_rm_files t/pod_coverage.t t/pod.t
+ sed -i -e '/^pod/d' t/test_manifest || die "Can't patch test_manifest"
+ perl-module_src_test
+}