summaryrefslogtreecommitdiff
path: root/dev-perl/Text-Markdown/Text-Markdown-1.0.31-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-perl/Text-Markdown/Text-Markdown-1.0.31-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-perl/Text-Markdown/Text-Markdown-1.0.31-r1.ebuild')
-rw-r--r--dev-perl/Text-Markdown/Text-Markdown-1.0.31-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-perl/Text-Markdown/Text-Markdown-1.0.31-r1.ebuild b/dev-perl/Text-Markdown/Text-Markdown-1.0.31-r1.ebuild
new file mode 100644
index 000000000000..9ae0ef4f3235
--- /dev/null
+++ b/dev-perl/Text-Markdown/Text-Markdown-1.0.31-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=BOBTFISH
+DIST_VERSION=1.000031
+inherit perl-module
+
+DESCRIPTION="Convert MultiMarkdown syntax to (X)HTML"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Digest-MD5
+ virtual/perl-Getopt-Long
+ virtual/perl-Text-Balanced
+"
+DEPEND="${RDEPEND}
+ test? (
+ virtual/perl-Test-Simple
+ dev-perl/Text-Diff
+ dev-perl/List-MoreUtils
+ dev-perl/Test-Differences
+ dev-perl/Test-Exception
+ )
+"
+
+mydoc="Readme.text"
+
+src_prepare() {
+ sed -i -e 's/use inc::Module::Install/use lib q[.]; use inc::Module::Install/' Makefile.PL ||
+ die "Can't patch Makefile.PL for 5.26 dot-in-inc"
+ perl-module_src_prepare
+}