summaryrefslogtreecommitdiff
path: root/dev-perl/Text-Aligner/Text-Aligner-0.160.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-25 20:21:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-25 20:21:45 +0100
commitc719fdcee603a5a706a45d10cb598762d56a727d (patch)
tree620cbf137661399a3fb1eff92914204f9a970713 /dev-perl/Text-Aligner/Text-Aligner-0.160.0.ebuild
parentcc4618c9ba3d974948ebf340b542d8cb01db2f55 (diff)
gentoo resync : 25.09.2021
Diffstat (limited to 'dev-perl/Text-Aligner/Text-Aligner-0.160.0.ebuild')
-rw-r--r--dev-perl/Text-Aligner/Text-Aligner-0.160.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-perl/Text-Aligner/Text-Aligner-0.160.0.ebuild b/dev-perl/Text-Aligner/Text-Aligner-0.160.0.ebuild
new file mode 100644
index 000000000000..328ad2a96a30
--- /dev/null
+++ b/dev-perl/Text-Aligner/Text-Aligner-0.160.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=SHLOMIF
+DIST_VERSION=0.16
+inherit perl-module
+
+DESCRIPTION="Used to justify strings to various alignment styles"
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ virtual/perl-Exporter
+ >=virtual/perl-Term-ANSIColor-2.20.0
+"
+BDEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-0.280.0
+ test? (
+ virtual/perl-File-Spec
+ virtual/perl-File-Temp
+ virtual/perl-IO
+ >=virtual/perl-Test-Simple-0.880.0
+ )
+"
+
+src_test() {
+ perl_rm_files t/release-{cpan-changes,kwalitee,trailing-space}.t \
+ t/author-{no-tabs,pod-{coverage,syntax}}.t
+
+ perl-module_src_test
+}