summaryrefslogtreecommitdiff
path: root/dev-perl/Text-Aligner/Text-Aligner-0.130.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-perl/Text-Aligner/Text-Aligner-0.130.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-perl/Text-Aligner/Text-Aligner-0.130.0.ebuild')
-rw-r--r--dev-perl/Text-Aligner/Text-Aligner-0.130.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-perl/Text-Aligner/Text-Aligner-0.130.0.ebuild b/dev-perl/Text-Aligner/Text-Aligner-0.130.0.ebuild
new file mode 100644
index 000000000000..e275dc06e89c
--- /dev/null
+++ b/dev-perl/Text-Aligner/Text-Aligner-0.130.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=SHLOMIF
+DIST_VERSION=0.13
+inherit perl-module
+
+DESCRIPTION="Used to justify strings to various alignment styles"
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Exporter
+ >=virtual/perl-Term-ANSIColor-2.20.0"
+DEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-0.280.0
+ test? (
+ virtual/perl-File-Spec
+ virtual/perl-File-Temp
+ virtual/perl-IO
+ virtual/perl-Test-Simple
+ )
+"
+src_test() {
+ perl_rm_files t/release-{cpan-changes,kwalitee,trailing-space}.t \
+ t/author-{no-tabs,pod-{coverage,syntax}}.t
+
+ perl-module_src_test
+}