summaryrefslogtreecommitdiff
path: root/dev-perl/Test-MockTime/Test-MockTime-0.150.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-perl/Test-MockTime/Test-MockTime-0.150.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-perl/Test-MockTime/Test-MockTime-0.150.0.ebuild')
-rw-r--r--dev-perl/Test-MockTime/Test-MockTime-0.150.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-perl/Test-MockTime/Test-MockTime-0.150.0.ebuild b/dev-perl/Test-MockTime/Test-MockTime-0.150.0.ebuild
new file mode 100644
index 000000000000..ed772a01a6d1
--- /dev/null
+++ b/dev-perl/Test-MockTime/Test-MockTime-0.150.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MODULE_AUTHOR=DDICK
+MODULE_VERSION=0.15
+inherit perl-module
+
+DESCRIPTION="Replaces actual time with simulated time"
+
+SLOT="0"
+KEYWORDS="~alpha amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="
+ virtual/perl-Time-Piece
+ virtual/perl-Time-Local
+ virtual/perl-Test-Simple
+"
+DEPEND="${RDEPEND}"
+
+SRC_TEST="do parallel"
+
+src_test() {
+ perl_rm_files t/pod.t
+ perl-module_src_test
+}