summaryrefslogtreecommitdiff
path: root/dev-perl/Test-MockModule/Test-MockModule-0.177.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /dev-perl/Test-MockModule/Test-MockModule-0.177.0.ebuild
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'dev-perl/Test-MockModule/Test-MockModule-0.177.0.ebuild')
-rw-r--r--dev-perl/Test-MockModule/Test-MockModule-0.177.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-perl/Test-MockModule/Test-MockModule-0.177.0.ebuild b/dev-perl/Test-MockModule/Test-MockModule-0.177.0.ebuild
new file mode 100644
index 000000000000..8924c6fcffc2
--- /dev/null
+++ b/dev-perl/Test-MockModule/Test-MockModule-0.177.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_VERSION=v${PV}
+DIST_AUTHOR=GFRANKS
+inherit perl-module
+
+DESCRIPTION="Override subroutines in a module for unit testing"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="
+ virtual/perl-Carp
+ >=dev-perl/SUPER-1.200.0
+ virtual/perl-Scalar-List-Utils
+"
+BDEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-0.380.0
+ test? (
+ >=virtual/perl-Test-Simple-0.880.0
+ dev-perl/Test-Warnings
+ )
+"
+
+PERL_RM_FILES=( "t/pod_coverage.t" "t/pod.t" )