summaryrefslogtreecommitdiff
path: root/dev-perl/Test-Inter/Test-Inter-1.90.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /dev-perl/Test-Inter/Test-Inter-1.90.0.ebuild
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'dev-perl/Test-Inter/Test-Inter-1.90.0.ebuild')
-rw-r--r--dev-perl/Test-Inter/Test-Inter-1.90.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-perl/Test-Inter/Test-Inter-1.90.0.ebuild b/dev-perl/Test-Inter/Test-Inter-1.90.0.ebuild
new file mode 100644
index 000000000000..44c7656e24fa
--- /dev/null
+++ b/dev-perl/Test-Inter/Test-Inter-1.90.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=SBECK
+DIST_VERSION=1.09
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="Framework for more readable interactive test scripts"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND=">=virtual/perl-ExtUtils-MakeMaker-6.300.0"
+RDEPEND="virtual/perl-IO"
+DEPEND="${RDEPEND}
+ test? (
+ dev-perl/File-Find-Rule
+ virtual/perl-Test-Simple
+ )
+"
+
+src_test() {
+ perl_rm_files t/pod_coverage.t t/pod.t
+ perl-module_src_test
+}