summaryrefslogtreecommitdiff
path: root/dev-perl/Test-Dependencies
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-perl/Test-Dependencies
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/Test-Dependencies')
-rw-r--r--dev-perl/Test-Dependencies/Manifest5
-rw-r--r--dev-perl/Test-Dependencies/Test-Dependencies-0.230.0.ebuild37
-rw-r--r--dev-perl/Test-Dependencies/files/Test-Dependencies-0.230.0-backcompat-test-more.patch78
-rw-r--r--dev-perl/Test-Dependencies/files/Test-Dependencies-0.230.0-no-heavy.patch287
-rw-r--r--dev-perl/Test-Dependencies/metadata.xml14
5 files changed, 421 insertions, 0 deletions
diff --git a/dev-perl/Test-Dependencies/Manifest b/dev-perl/Test-Dependencies/Manifest
new file mode 100644
index 000000000000..56d50d7862cf
--- /dev/null
+++ b/dev-perl/Test-Dependencies/Manifest
@@ -0,0 +1,5 @@
+AUX Test-Dependencies-0.230.0-backcompat-test-more.patch 1978 BLAKE2B df3ab1a45a96f85c5aca19d17c30a8ba70020a7b0e175cf857e8cec3a9d5b89cc57ac55875eb0793d0120830562cae221b4acb5dbfea3da3f83046375e4226bf SHA512 e86a7765b63701bf43aaac894661b8c21139592597e9f6b0fac2c3888de48d0df24f4c65f95bf8104cccb7ea73801613ea3a53630478f3f1156b6405db145aa8
+AUX Test-Dependencies-0.230.0-no-heavy.patch 7958 BLAKE2B 0465926b0c48198c13a0b01960f23c916e55dc2a5ccd7851634bddd632860105870f064ecfa62d5db9dc84829cd84d99e0fc0f6c1d0d3c40fd8cb09d3145f369 SHA512 cef9d9a6254b675de527d5a2bd7ab4f2371b39dc88b3110dac9c12b7a7f73a2649059358382be6851b82e815004050aed617f4ad45b4501552dad152d2dec6d8
+DIST Test-Dependencies-0.23.tar.gz 16324 BLAKE2B 2d148062b3f4a1967ed73c42a9aba424bb6f9e605fee96aeddea2ad85eed00fdc76454f0a379ace2437ead27553efbcff1f812f2155ac0b5b4d127b143c700e6 SHA512 cfbf3c337e8a26d1f4803d788a67399e7d87b611d4d9c4b3c942893212d9f7b614f45c03dacd19f081a25010f11e5e24ffe704196fc92cfd9466dd1ad84d48c3
+EBUILD Test-Dependencies-0.230.0.ebuild 823 BLAKE2B 5b9d9d3723dc410bc20e5e75fd55781d4f0fa96e3a7a7667dffdfa4501efe22f844d8e3e4090218b0ca8a0b37f9a03ae7818a01952ba70f9f449a7fbb7229c29 SHA512 725e3c0e7cf2fad6c84f68ed05b1b4e0aad0e04202e1bb8db030c2005521b1dbf271024b3c57856c59224feb168756cb9030c61512517c233f684fbf1ceefe44
+MISC metadata.xml 550 BLAKE2B 15f0ee5b003ba08b1fddd0d89fc8cd4b620a0c8e1c882be0dfd575f5228c21b1285daf288b161345edb051f6e310d88e9c6466f7d6023d4e300dd6b8badf4ffb SHA512 2af44a435265ff7ee3730a548148069771bf5bb9d7a193efb29232c7b2e7685e4c5cebb849519515d01d3191e108f8c58358c0a1a159b84b0f15eef418b8835a
diff --git a/dev-perl/Test-Dependencies/Test-Dependencies-0.230.0.ebuild b/dev-perl/Test-Dependencies/Test-Dependencies-0.230.0.ebuild
new file mode 100644
index 000000000000..567f8323af2b
--- /dev/null
+++ b/dev-perl/Test-Dependencies/Test-Dependencies-0.230.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=EHUELS
+DIST_VERSION=0.23
+inherit perl-module
+
+DESCRIPTION="Ensure that your dependency listing is complete"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+PATCHES=(
+ "${FILESDIR}/${P}-no-heavy.patch"
+ "${FILESDIR}/${P}-backcompat-test-more.patch"
+)
+RDEPEND="
+ virtual/perl-CPAN-Meta
+ dev-perl/File-Find-Rule-Perl
+ virtual/perl-Module-CoreList
+ dev-perl/Pod-Strip
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-CPAN-Meta-Requirements-2.120.620
+ virtual/perl-ExtUtils-MakeMaker
+ virtual/perl-Module-Metadata
+ test? (
+ >=virtual/perl-Test-Simple-0.980.0
+ )
+"
+pkg_postinst() {
+ einfo 'Test::Dependencies::Heavy is now defunct in this release.'
+ einfo 'Read `perldoc Test::Dependencies::Heavy` for details.'
+}
diff --git a/dev-perl/Test-Dependencies/files/Test-Dependencies-0.230.0-backcompat-test-more.patch b/dev-perl/Test-Dependencies/files/Test-Dependencies-0.230.0-backcompat-test-more.patch
new file mode 100644
index 000000000000..af1bc2e506dc
--- /dev/null
+++ b/dev-perl/Test-Dependencies/files/Test-Dependencies-0.230.0-backcompat-test-more.patch
@@ -0,0 +1,78 @@
+From 459bee47f8fccac28f13f60e9c20c65c7125ae00 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentfredric@gmail.com>
+Date: Tue, 12 Sep 2017 08:22:02 +1200
+Subject: Weaken Test::More requirements
+
+---
+ META.json | 2 +-
+ META.yml | 2 +-
+ Makefile.PL | 4 ++--
+ t/00-load-basic.t | 4 ++--
+ 4 files changed, 6 insertions(+), 6 deletions(-)
+
+diff --git a/META.json b/META.json
+index cd9ff8d..7bd675d 100644
+--- a/META.json
++++ b/META.json
+@@ -53,7 +53,7 @@
+ },
+ "test" : {
+ "requires" : {
+- "Test::More" : "1.30"
++ "Test::More" : "0.98"
+ }
+ }
+ },
+diff --git a/META.yml b/META.yml
+index 01e1e21..da65985 100644
+--- a/META.yml
++++ b/META.yml
+@@ -3,7 +3,7 @@ abstract: 'Verify dependencies in META.yml or cpanfile'
+ author:
+ - 'Erik Huelsmann <ehuels@gmail.com>'
+ build_requires:
+- Test::More: '1.30'
++ Test::More: '0.98'
+ configure_requires:
+ CPAN::Meta::Requirements: '2.120620'
+ ExtUtils::MakeMaker: '0'
+diff --git a/Makefile.PL b/Makefile.PL
+index c3b1e51..0357e7e 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -22,7 +22,7 @@ my %WriteMakefileArgs = (
+ "Pod::Strip" => 0
+ },
+ "TEST_REQUIRES" => {
+- "Test::More" => "1.30",
++ "Test::More" => "0.98",
+ },
+ "VERSION" => "0.23",
+ "test" => {
+@@ -33,7 +33,7 @@ my %WriteMakefileArgs = (
+
+ my %FallbackPrereqs = (
+ "Pod::Strip" => 0,
+- "Test::More" => "1.30",
++ "Test::More" => "0.98",
+ );
+
+ # inserted by Dist::Zilla::Plugin::DynamicPrereqs 0.029
+diff --git a/t/00-load-basic.t b/t/00-load-basic.t
+index 80fdebd..69ddd5f 100644
+--- a/t/00-load-basic.t
++++ b/t/00-load-basic.t
+@@ -2,8 +2,8 @@
+
+ use Test::More 0.98;
+
+-plan skip_all => 'Tests incompatible with Test::More 1.001014'
+- if $Test::More::VERSION == 1.001014;
++plan skip_all => 'Tests incompatible with Test::More <=1.300000'
++ unless eval {Test::More->VERSION(1.300000)};
+
+ use_ok('Test::Dependencies');
+ use_ok('Test::Dependencies::Light');
+--
+2.14.1
+
diff --git a/dev-perl/Test-Dependencies/files/Test-Dependencies-0.230.0-no-heavy.patch b/dev-perl/Test-Dependencies/files/Test-Dependencies-0.230.0-no-heavy.patch
new file mode 100644
index 000000000000..38d132f7b0dd
--- /dev/null
+++ b/dev-perl/Test-Dependencies/files/Test-Dependencies-0.230.0-no-heavy.patch
@@ -0,0 +1,287 @@
+From c19543dcd12858d0852a9f0dc0641eaa5b52a038 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentfredric@gmail.com>
+Date: Tue, 12 Sep 2017 07:40:39 +1200
+Subject: Axe Test::Dependencies::Heavy
+
+---
+ MANIFEST | 1 -
+ META.json | 23 +++--------------------
+ META.yml | 6 ------
+ Makefile.PL | 8 --------
+ dist.ini | 7 -------
+ lib/Test/Dependencies.pm | 4 ++--
+ lib/Test/Dependencies/Heavy.pm | 36 ++++++++++++++++++++++++++++++++++--
+ t/00-load-basic.t | 7 -------
+ t/05-dependencies-heavy.t | 12 ------------
+ 9 files changed, 39 insertions(+), 65 deletions(-)
+ delete mode 100644 t/05-dependencies-heavy.t
+
+diff --git a/MANIFEST b/MANIFEST
+index fddccd7..4780f3d 100644
+--- a/MANIFEST
++++ b/MANIFEST
+@@ -16,7 +16,6 @@ t/01-load-with-exclude.t
+ t/02-dependencies-default.t
+ t/03-empty.t
+ t/04-dependencies-light.t
+-t/05-dependencies-heavy.t
+ t/data/empty/dummy
+ t/data/mostly-empty/META.yml
+ t/data/mostly-empty/lib/empty
+diff --git a/META.json b/META.json
+index 24b6d31..cd9ff8d 100644
+--- a/META.json
++++ b/META.json
+@@ -14,18 +14,6 @@
+ },
+ "name" : "Test-Dependencies",
+ "optional_features" : {
+- "Heavy" : {
+- "description" : "\"Heavy\" dependency search policy",
+- "prereqs" : {
+- "runtime" : {
+- "requires" : {
+- "B::PerlReq" : "0",
+- "PerlReq::Utils" : "0"
+- }
+- }
+- },
+- "x_default" : "0"
+- },
+ "Legacy" : {
+ "description" : "Legacy (no-arguments) ok_dependencies() invocation",
+ "prereqs" : {
+@@ -49,10 +37,8 @@
+ },
+ "develop" : {
+ "requires" : {
+- "B::PerlReq" : "0",
+ "CPAN::Meta" : "0",
+- "File::Find::Rule::Perl" : "0",
+- "PerlReq::Utils" : "0"
++ "File::Find::Rule::Perl" : "0"
+ }
+ },
+ "runtime" : {
+@@ -61,16 +47,13 @@
+ "perl" : "v5.10.1"
+ },
+ "suggests" : {
+- "B::PerlReq" : "0",
+ "CPAN::Meta" : "0",
+- "File::Find::Rule::Perl" : "0",
+- "PerlReq::Utils" : "0"
++ "File::Find::Rule::Perl" : "0"
+ }
+ },
+ "test" : {
+ "requires" : {
+- "Test::More" : "1.30",
+- "Test::Needs" : "0"
++ "Test::More" : "1.30"
+ }
+ }
+ },
+diff --git a/META.yml b/META.yml
+index 45176e6..01e1e21 100644
+--- a/META.yml
++++ b/META.yml
+@@ -4,7 +4,6 @@ author:
+ - 'Erik Huelsmann <ehuels@gmail.com>'
+ build_requires:
+ Test::More: '1.30'
+- Test::Needs: '0'
+ configure_requires:
+ CPAN::Meta::Requirements: '2.120620'
+ ExtUtils::MakeMaker: '0'
+@@ -17,11 +16,6 @@ meta-spec:
+ version: '1.4'
+ name: Test-Dependencies
+ optional_features:
+- Heavy:
+- description: '"Heavy" dependency search policy'
+- requires:
+- B::PerlReq: '0'
+- PerlReq::Utils: '0'
+ Legacy:
+ description: 'Legacy (no-arguments) ok_dependencies() invocation'
+ requires:
+diff --git a/Makefile.PL b/Makefile.PL
+index 57708c2..c3b1e51 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -23,7 +23,6 @@ my %WriteMakefileArgs = (
+ },
+ "TEST_REQUIRES" => {
+ "Test::More" => "1.30",
+- "Test::Needs" => 0
+ },
+ "VERSION" => "0.23",
+ "test" => {
+@@ -35,7 +34,6 @@ my %WriteMakefileArgs = (
+ my %FallbackPrereqs = (
+ "Pod::Strip" => 0,
+ "Test::More" => "1.30",
+- "Test::Needs" => 0
+ );
+
+ # inserted by Dist::Zilla::Plugin::DynamicPrereqs 0.029
+@@ -44,12 +42,6 @@ if (has_module('CPAN::Meta') && has_module('File::Find::Rule::Perl')
+ requires('CPAN::Meta');
+ requires('File::Find::Rule::Perl');
+ }
+-if (has_module('B::PerlReq') && has_module('PerlReq::Utils')
+- || prompt('install "Heavy" dependency search policy? [y/N]', 'N') =~ /^y/i) {
+- requires('B::PerlReq');
+- requires('PerlReq::Utils');
+-}
+-
+
+ unless ( eval { ExtUtils::MakeMaker->VERSION(6.63_03) } ) {
+ delete $WriteMakefileArgs{TEST_REQUIRES};
+diff --git a/dist.ini b/dist.ini
+index abcc46b..885da23 100644
+--- a/dist.ini
++++ b/dist.ini
+@@ -22,7 +22,6 @@ Pod::Strip = 0
+ [Prereqs / TestRequires]
+ Test::More = 1.30
+ ; ' all versions up to 1.1.14 have a bug with 'plan' leaking from 'use_ok'
+-Test::Needs = 0
+
+ [OptionalFeature / Legacy]
+ -default = 1
+@@ -30,12 +29,6 @@ Test::Needs = 0
+ CPAN::Meta = 0
+ File::Find::Rule::Perl = 0
+
+-[OptionalFeature / Heavy]
+--default = 0
+--description = "Heavy" dependency search policy
+-B::PerlReq = 0
+-PerlReq::Utils = 0
+-
+ ; [MetaNoIndex]
+ ; directory = t-data
+
+diff --git a/lib/Test/Dependencies.pm b/lib/Test/Dependencies.pm
+index 31f0783..6a1bd69 100644
+--- a/lib/Test/Dependencies.pm
++++ b/lib/Test/Dependencies.pm
+@@ -110,7 +110,7 @@ sub import {
+ if (defined $args{style}) {
+ _choose_style($args{style});
+ } else {
+- _choose_style('heavy');
++ _choose_style('light');
+ }
+ }
+
+@@ -122,7 +122,7 @@ sub _choose_style {
+ if (lc $style eq 'light') {
+ eval 'use Test::Dependencies::Light';
+ } elsif (lc $style eq 'heavy') {
+- eval 'use Test::Dependencies::Heavy';
++ require Test::Dependencies::Heavy;
+ } else {
+ carp "Unknown style: '", $style, "'";
+ }
+diff --git a/lib/Test/Dependencies/Heavy.pm b/lib/Test/Dependencies/Heavy.pm
+index 5a78f7f..121b8f1 100644
+--- a/lib/Test/Dependencies/Heavy.pm
++++ b/lib/Test/Dependencies/Heavy.pm
+@@ -3,9 +3,14 @@ package Test::Dependencies::Heavy;
+ use warnings;
+ use strict;
+
+-use B::PerlReq;
++BEGIN {
++ die <<'EOF';
++Test::Dependencies::Heavy is not available on Gentoo
++Read `perldoc Test::Dependencies::Heavy` for details
++EOF
++}
++
+ use IPC::Cmd qw/run/;
+-use PerlReq::Utils qw(path2mod);
+ use Exporter 'import';
+
+ our @EXPORT = qw/get_modules_used_in_file/;
+@@ -14,6 +19,33 @@ our @EXPORT = qw/get_modules_used_in_file/;
+
+ Test::Dependencies::Heavy - Heavy style for checking for dependencies.
+
++=head1 REMOVED
++
++This package has been neutered by Gentoo as its primary dependencies,
++L<< C<B::PerlReq>|B::PerlReq >> and L<< C<PerlReq::Utils>|PerlReq::Utils >>
++( shipped in C<dev-perl/rpm-build-perl> ) are broken upstream since Perl 5.22,
++and upstream haven't been seen since 2012.
++
++Given that nobody in Gentoo noticed this other than Arch Testing, is safe to
++assume its dead.
++
++If the issues with C<rpm-build-perl> can be restored, this removal can be
++reverted.
++
++Related Bugs:
++
++=over 4
++
++=item * L<< RT#117350 - Compilation error with op_sibling on Perl 5.26|https://rt.cpan.org/Public/Bug/Display.html?id=117350 >>
++
++=item * L<< RT#104855 - Runtime Tests fail since Perl 5.22|https://rt.cpan.org/Public/Bug/Display.html?id=104885 >>
++
++=item * L<< Gentoo#623095 - Compile failure on Perl 5.26|https://bugs.gentoo.org/623096 >>
++
++=item * L<< Gentoo#627080 - Runtime tests fail|https://bugs.gentoo.org/627080 >>
++
++=back
++
+ =head1 SYNOPSIS
+
+ You shouldn't have to include this module yourself. Look at the
+diff --git a/t/00-load-basic.t b/t/00-load-basic.t
+index d776b3d..80fdebd 100644
+--- a/t/00-load-basic.t
++++ b/t/00-load-basic.t
+@@ -1,18 +1,11 @@
+ #!perl
+
+ use Test::More 0.98;
+-use Test::Needs;
+
+ plan skip_all => 'Tests incompatible with Test::More 1.001014'
+ if $Test::More::VERSION == 1.001014;
+
+-
+ use_ok('Test::Dependencies');
+ use_ok('Test::Dependencies::Light');
+
+-subtest "Heavy Loading" => sub {
+- test_needs 'B::PerlReq', 'PerlReq::Utils';
+- use_ok('Test::Dependencies::Heavy');
+-};
+-
+ done_testing;
+diff --git a/t/05-dependencies-heavy.t b/t/05-dependencies-heavy.t
+deleted file mode 100644
+index dd9972f..0000000
+--- a/t/05-dependencies-heavy.t
++++ /dev/null
+@@ -1,12 +0,0 @@
+-#!perl
+-
+-use Test::Needs 'B::PerlReq', 'PerlReq::Utils';
+-
+-# yay bootstrap!
+-use Test::Dependencies exclude => [
+- qw/Test::Dependencies
+- ExtUtils::MakeMaker CPAN::Meta::Requirements Module::Metadata /
+- ],
+- style => 'heavy';
+-
+-ok_dependencies();
+--
+2.14.1
+
diff --git a/dev-perl/Test-Dependencies/metadata.xml b/dev-perl/Test-Dependencies/metadata.xml
new file mode 100644
index 000000000000..67ee79d2c8e2
--- /dev/null
+++ b/dev-perl/Test-Dependencies/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">Test-Dependencies</remote-id>
+ <remote-id type="cpan-module">Test::Dependencies</remote-id>
+ <remote-id type="cpan-module">Test::Dependencies::Heavy</remote-id>
+ <remote-id type="cpan-module">Test::Dependencies::Light</remote-id>
+ </upstream>
+</pkgmetadata>