summaryrefslogtreecommitdiff
path: root/dev-perl/Sys-Virt/Sys-Virt-10.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-14 06:47:04 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-14 06:47:04 +0000
commit404b23b9395fafe5c40a1fd4d859c6cd17b4a646 (patch)
tree789ba7b9b17a99ad3ccbf05a131086babface825 /dev-perl/Sys-Virt/Sys-Virt-10.1.0.ebuild
parent633a3741c9483bd63e8c29b276d2af636ec8b390 (diff)
gentoo auto-resync : 14:03:2024 - 06:47:03
Diffstat (limited to 'dev-perl/Sys-Virt/Sys-Virt-10.1.0.ebuild')
-rw-r--r--dev-perl/Sys-Virt/Sys-Virt-10.1.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-perl/Sys-Virt/Sys-Virt-10.1.0.ebuild b/dev-perl/Sys-Virt/Sys-Virt-10.1.0.ebuild
new file mode 100644
index 000000000000..16cad8c07a60
--- /dev/null
+++ b/dev-perl/Sys-Virt/Sys-Virt-10.1.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Packages which get releases together:
+# app-emacs/nxml-libvirt-schemas
+# dev-python/libvirt-python
+# dev-perl/Sys-Virt
+# app-emulation/libvirt
+# Please bump them together!
+
+DIST_AUTHOR=DANBERR
+DIST_VERSION=v${PV}
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="API for using the libvirt library from Perl"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+RDEPEND="
+ >=app-emulation/libvirt-${PV}
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-CBuilder
+ dev-perl/Module-Build
+ virtual/pkgconfig
+ test? (
+ dev-perl/CPAN-Changes
+ dev-perl/Test-More-UTF8
+ dev-perl/Test-Pod-Coverage
+ dev-perl/XML-XPath
+ virtual/perl-Test-Simple
+ virtual/perl-Time-HiRes
+ )"
+DEPEND="
+ >=app-emulation/libvirt-${PV}
+"