summaryrefslogtreecommitdiff
path: root/dev-perl/Software-License/Software-License-0.103.12.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-perl/Software-License/Software-License-0.103.12.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-perl/Software-License/Software-License-0.103.12.ebuild')
-rw-r--r--dev-perl/Software-License/Software-License-0.103.12.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-perl/Software-License/Software-License-0.103.12.ebuild b/dev-perl/Software-License/Software-License-0.103.12.ebuild
new file mode 100644
index 000000000000..a718d8d9bd8f
--- /dev/null
+++ b/dev-perl/Software-License/Software-License-0.103.12.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+DIST_AUTHOR=RJBS
+DIST_VERSION=0.103012
+inherit perl-module
+
+DESCRIPTION="packages that provide templated software licenses"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+# r: IO::Dir -> IO
+# r: strict, warnings -> perl
+RDEPEND="
+ virtual/perl-Carp
+ dev-perl/Data-Section
+ virtual/perl-File-Spec
+ virtual/perl-IO
+ virtual/perl-Module-Load
+ dev-perl/Text-Template
+ virtual/perl-parent
+"
+DEPEND="
+ >=virtual/perl-ExtUtils-MakeMaker-6.300.0
+ test? (
+ >=virtual/perl-Test-Simple-0.960.0
+ dev-perl/Try-Tiny
+ )
+"