summaryrefslogtreecommitdiff
path: root/dev-perl/SNMP_Session
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-perl/SNMP_Session
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/SNMP_Session')
-rw-r--r--dev-perl/SNMP_Session/Manifest4
-rw-r--r--dev-perl/SNMP_Session/SNMP_Session-1.13-r2.ebuild23
-rw-r--r--dev-perl/SNMP_Session/files/SNMP_Session-1.13-Socket6.patch20
-rw-r--r--dev-perl/SNMP_Session/metadata.xml12
4 files changed, 59 insertions, 0 deletions
diff --git a/dev-perl/SNMP_Session/Manifest b/dev-perl/SNMP_Session/Manifest
new file mode 100644
index 000000000000..112d744baf92
--- /dev/null
+++ b/dev-perl/SNMP_Session/Manifest
@@ -0,0 +1,4 @@
+AUX SNMP_Session-1.13-Socket6.patch 660 BLAKE2B 6f7d13bc159b21b7b1146cc2be7d43a09191e90078f51ee056e0c010adfd971db51a69cc3ced8867779363850606d98b9e28f69ca8064064114cb5bf94dca1a1 SHA512 c1400614c1e4731f74b153e6c2b38ad30f71276d350ea7e7bf35f1cd8d957a26612531290f9bb8a88b235c8d1372416f0197a7efbe66fc4c5748c899af59b806
+DIST SNMP_Session-1.13.tar.gz 65738 BLAKE2B 0b0232003abc1528b4de1ab20b14421d0e5fc8845f1a6956fbccb87842b0d3aff3d8d0b6d9460d4beae16020f5ea1c6e2a0170da376eb23abd70451ddf89deae SHA512 5185739cfe1c37f7087136b23f3fb1eb5daa9d1ab2036d8bbf36438b0a9ede354daca73567529c96297f2621842dfb4c7832101306cee1540ee950b4d0bfe6a8
+EBUILD SNMP_Session-1.13-r2.ebuild 513 BLAKE2B 58be88fddcbe8a01355857de413f6d04f6bb0eea78ea9487c9c4b3624dd6436917bdd176caf656da3907718ce1c6c8622244f0beef84e41c987b2db26c660883 SHA512 ee7f46b43ba54648a38c640f4d53a00a35b56342536bc7b9cc351a9744d7080602c8716dfbc571476a0a7d21a7bf833061e7e55e6b568fbbe233e1253ec94d7d
+MISC metadata.xml 393 BLAKE2B f08e36347e6571435a67c4a713a7951d4aeeddf2aa59400995fab3b8660933e60ba78e431f3e79df3a9313b6522c7f2fcdc9f8f53145a284a4da18cc0a8c443f SHA512 3cc8f0f8a90408421dc080e4a2274b0bc3bf08ac20187fdf5525d3fc35bdd3cf39c03c64afcf25f39a36322036aea8b867c250fe095ed03f2bf4ea893192afd3
diff --git a/dev-perl/SNMP_Session/SNMP_Session-1.13-r2.ebuild b/dev-perl/SNMP_Session/SNMP_Session-1.13-r2.ebuild
new file mode 100644
index 000000000000..64fc52034cfa
--- /dev/null
+++ b/dev-perl/SNMP_Session/SNMP_Session-1.13-r2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit perl-module
+
+DESCRIPTION="A SNMP Perl Module"
+SRC_URI="https://dev.gentoo.org/~dilfridge/distfiles/${P}.tar.gz"
+HOMEPAGE="https://github.com/sleinen/snmp-session"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~sparc-solaris ~x86-solaris"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-Socket6.patch
+)
+
+src_install() {
+ perl-module_src_install
+ dohtml index.html
+}
diff --git a/dev-perl/SNMP_Session/files/SNMP_Session-1.13-Socket6.patch b/dev-perl/SNMP_Session/files/SNMP_Session-1.13-Socket6.patch
new file mode 100644
index 000000000000..27d8081b31cc
--- /dev/null
+++ b/dev-perl/SNMP_Session/files/SNMP_Session-1.13-Socket6.patch
@@ -0,0 +1,20 @@
+--- a/lib/SNMP_Session.pm Fri Nov 21 05:25:17 2008
++++ b/lib/SNMP_Session.pm Tue Mar 16 16:14:22 2010
+@@ -146,7 +146,7 @@ BEGIN {
+
+ if (eval {local $SIG{__DIE__};require Socket6;} &&
+ eval {local $SIG{__DIE__};require IO::Socket::INET6; IO::Socket::INET6->VERSION("1.26");}) {
+- import Socket6;
++ Socket6->import(qw(inet_pton getaddrinfo));
+ $ipv6_addr_len = length(pack_sockaddr_in6(161, inet_pton(AF_INET6(), "::1")));
+ $SNMP_Session::ipv6available = 1;
+ }
+@@ -605,7 +605,7 @@ use Carp;
+ BEGIN {
+ if($SNMP_Session::ipv6available) {
+ import IO::Socket::INET6;
+- import Socket6;
++ Socket6->import(qw(inet_pton getaddrinfo));
+ }
+ }
+
diff --git a/dev-perl/SNMP_Session/metadata.xml b/dev-perl/SNMP_Session/metadata.xml
new file mode 100644
index 000000000000..ab545368268e
--- /dev/null
+++ b/dev-perl/SNMP_Session/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="google-code">snmp-session</remote-id>
+ <remote-id type="github">sleinen/snmp-session</remote-id>
+ </upstream>
+</pkgmetadata>